iTunes crashes when syncing iPhone 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wrn815, Sep 9, 2010.

  1. wrn815 macrumors newbie

    Joined:
    Sep 9, 2010
    #1
    Hi, I am currently having syncing issues with my iPhone 3G which is running on a 4.0.2 version of firmware and iTunes 10 on a pc which is running on Windows Vista.

    The problem is, everytime I sync, iTunes would just crash and an I get an error message saying "iTunes has stopped working". Before, I would even get a message on my taskbar saying "Data Execution Prevention has closed iTunes". I've disabled both DEP and UAC on my PC, but to no avail. I've also tried authorizing and de-authorizing iTunes and uninstalling and re-installing iTunes, but still, nothing.

    Once when I tried to sync, iTunes erased my whole library of songs and videos. I tried restoring, and iTunes just wiped my phone of all my apps and basically everything it contained. Good thing I was able to retrieve my contacts and notes through my back-up files.

    So, I am literally stuck with a junk iPhone that can only perform the basic functions of an ordinary cellphone, plus internet browsing. Anyone got any ideas? I'd highly appreciate it.
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Try a different computer, to make sure it’s nothing on the iPhone. If not, you may need to do a total uninstall of all Apple stuff dealing with iTunes. Another avenue for you, since you’re on Vista, is to go to an earlier restore point when this wasn’t occurring.
     
  3. wrn815 thread starter macrumors newbie

    Joined:
    Sep 9, 2010
    #3
    About syncing on another computer, yes I have tried that. I installed iTunes on my laptop and it still does not work. Although, it is still quite possible that a file in my iTunes library is causing this, since I practically just transferred the iTunes library on my PC to my laptop. Will try syncing on some other computer with a different library.

    I've also tried doing several system restores, but what happens is iTunes is not able to find quicktime and cannot open. I recently discovered that I can fix this by simply repairing both programs in the control panel. However, the restore point for the last time I was able to sync, (Around August 15, if i'm not mistaken) has sadly been deleted from the list of restore points.
     

Share This Page