iTunes crashing after a OWC Data Doubler installed

Discussion in 'MacBook Pro' started by Polska, Apr 22, 2011.

  1. Polska macrumors member

    Joined:
    Mar 9, 2008
    Location:
    Rio de Janeiro - RJ
    #1
    Hey all,

    I am desperate for help.

    10 days ago I successfully installed the OWC data doubler with a 120gb SSD on my optical driver's bay. I migrate the system and the Applications folder successfully and everything seems to be working fine. Well, ALMOST everything. My iTunes keeps giving the message: "You do not have enough privileges for this operation". I tried it all and still have this problems: Here is the things that I tried:

    - I checked all the files/folder permissions from iTunes and iTunes folder and I do have access to them.
    - I completely removed iTunes and it's plist files and reinstalled the latest (version 10.2.2 ) and still giving the same message.
    - I moved my iTunes library to force iTunes to create a new library.
    - I noticed if I boot from my former HDD instead of the SSD, the itunes still works fine so I thought it was a kind of conflict so I removed completely the iTunes from the HDD but the problem persists.

    As a title of information, my Users folders is located at the HDD and the system/applications files are on the SSD. I do not have space to move my iTunes library to the SSD, as some suggested.

    Please, I am desperate. I need to sync my iPhone/iPad and I am not being able for a while.

    Thanks!
    Erick Pessôa
     
  2. rederic8 macrumors newbie

    Joined:
    May 6, 2011
    #2
    any progress on this? I just had the exact same problem.
     
  3. msriotdoll macrumors member

    Joined:
    Dec 1, 2005
    #3
    i had the same issue with itunes.. how i solved it was go into the SSD and under your users folder do <<command i >>and make sure you have permissions set to read/write.
    Do the same for your users folder on your data drive.
    I have a users folder on my ssd and data drive.
    Run disk utility>repair premissions and see if that works for you.
     
  4. rederic8 macrumors newbie

    Joined:
    May 6, 2011
    #4
    my issue solved

    ok.. i solved my issue. fixing permissions on the users directory wasn't it for me. this is not the same solution that several others have posted on this problem. I had to create a /Users/Shared directory on my SSD and change its permissions to be 1777
    in the following article the guy mentions having this problem and how to fix it.
    http://the-plot.com/blog/?p=600

    you might check if your Shared directory is there under your SSD. if not, then do this

    oh, one more thing.. the path to the Users directory that needs /Shared is not what the apple article says (if you set up your ssd like I did). it is /Volumes/YourSSDhd/Users/Shared
     

Share This Page