iTunes: Custom radio stations simply dont work

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by phobox, Jul 24, 2015.

  1. phobox macrumors member

    Joined:
    Dec 25, 2007
    #1
    So Im not sure if anyone else has been experiencing this, Ive not found any threads here or elsewhere dealing exactly with this issue so Im starting to think Im the only one.
    In iTunes with Apple Music we have the ability to right click any track and start a radio station based on the artist or the song, except neither of these options function. Clicking either option results in nothing happening and whatever you may have been playing at the time simply stops. Does anyone know why this is happening and/or if theres a fix?

    FYI, this is on iTunes 12.2.1 on OS X Yosemite 10.10.5.
     
  2. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #2
    Have same exact setup here and it works just fine.
     
  3. flur macrumors 68000

    Joined:
    Nov 12, 2012
    #3
    No issues here either. Honestly, it's the only feature I use.

    I do wish they'd let us create stations based on an album.
     
  4. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #4
    No problems here, nor on my macbook running El Capitan.
     
  5. Arndroid macrumors 6502a

    Arndroid

    Joined:
    Oct 3, 2013
    #5
    It may appear like nothing is happening but the radio station has started with the current song you based the station on. If you skip to next song you will see you are on the radio station. Also the heart is replaced with a star.

    First couple times I tried it I thought it wasn't doing anything either
     
  6. phobox thread starter macrumors member

    Joined:
    Dec 25, 2007
    #6
    It definitely isnt working. Whatever I'm playing at the time (if anything) stops and the little playback status bit with the song info, stars/hearts etc goes back to the Apple logo... Just as if I literally hit the stop button. It simply doesn't work here which is very strange because apparently it's working for others.
     
  7. PhiLLoW macrumors 6502

    Joined:
    May 31, 2014

Share This Page