iTunes Determining Gapless Playback

Discussion in 'Mac Apps and Mac App Store' started by skate71290, Sep 3, 2010.

  1. skate71290 macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #1
    Hey, just moved my whole iTunes library (21560 songs) to my 2TB Time Capsule... And well everything went great, until I updated to iTunes 10, it updated the iTunes library on open, fine, took two minutes on the ageing MBA, but now, it is Determining gapless playback for my entire library... And it's been going for about 6 hours and it's on 856/21560, so my question is... Is there anyway to stop iTunes doing this? I tried a Force Quit and doesn't help as it just resumes, from the start! Regards, skate71290
     
  2. Orange™ macrumors 6502

    Joined:
    Apr 24, 2010
    #2
    Where did you get all those songs? Piracy is not supported on this website so you might as well end this thread now.

    20,000+ songs? Really? To put that in perspective, that is equivalent to 2,000 CD's/Albums. :rolleyes:

    Maybe it wouldn't take so long if you didn't have so many songs? :rolleyes:

    (P.S. Why don't you want it to finish?)
     
  3. Brien macrumors 68020

    Brien

    Joined:
    Aug 11, 2008
    #3
    21,000 songs is chump change for some people.
     
  4. skate71290 thread starter macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #4
    I do love how people always jump to the wrong conclusion... I have been collecting CDs since I started working 6 years ago, and the rest are 100% legal mixtapes (such as Eminem and Lil Wayne) and the others are Live Sets from the likes of Tiesto and Armin Van Buuren... So instead of bitching about my music addiction, actually helping me would be nice...
     
  5. FourCandles macrumors 6502a

    Joined:
    Feb 10, 2009
    Location:
    England
    #5
    Sounds like letting it finish could be the best option....but a couple of ideas:

    If you enable Crossfade it should kill gapless playback, then give you time to batch edit your tracks and select/deselect the Gapless Album option.

    If that's no good and this is really bugging you, it may be worth creating a new empty library, getting the settings right and then importing your albums in chunks so that the "Determining" doesn't take too long.
     
  6. ReggaeFire macrumors 6502

    Joined:
    Mar 19, 2003
    #6
    I know I'm feeding a troll, but what the heck. There are sad people out there who spend decades collecting music. After a couple decades buying a few albums every week, you'd be unsurprised to discover they have gigantic collections and are nerdy enough to encode them all and have them categorized pretty rigorously. Their own spouses don't understand it, but there it is. And that's how you end up with iTunes music libraries of 70,000 songs or so. :)

    Oh and 20,000 songs is more likely closer to 1300 albums.
     
  7. skate71290 thread starter macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #7
    I'm only 20 :) and I copied them as and when I got them, only 128kbps, I'm not THAT nerdy lol
     
  8. Azagar macrumors member

    Azagar

    Joined:
    Nov 29, 2008
    Location:
    San Francisco
    #8
    Almost 100% sure there is no way to stop it because i'm assuming all your music has the gapless album option checked correct? Only way to stop it would be to uncheck it on all your music ( that alone will take a long time considering all that music is over your network and not on your HD. )

    Is there a reason you did that by the way? My music collection is only 1/4, all perfect ID3 tags and artwork :D, of yours but would never trust it to my time capsule after all those reports on the HD in them falling.
     
  9. skate71290 thread starter macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #9
    Thanks for the help, it's so god damn annoying lol, Gapless Playback is enabled for every song and yes turning it off would take freaking ages, it took 10 minutes to do the first song, and if you check my Signature I only have an 80GB MacBook Air for a 300GB Library lol :( would a Bus-Powered external hard drive work better? I might treat myself to a new 13" laptop for Christmas, but then again 500GB isn't a lot really it soon disappears lol
     
  10. Azagar macrumors member

    Azagar

    Joined:
    Nov 29, 2008
    Location:
    San Francisco
    #10
    Yea if you moved it to an external drive it would be faster, but the time it would take to copy your library to the drive plus the time needed to let it finish analyzing the playback may just be the same amount, or close to it, of just letting it finish off your Time Capsule.

    You think maybe if you connected your MBA to your Time capsule through ethernet it would go faster? I'm trying to think if this will make an impact, I would think the gigabit speeds would help big time vs wifi that you'r using now. But you need that adapter right?
     
  11. skate71290 thread starter macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #11
    I bought the adapter ages ago thinking it would be faster, but for some strnge reason I actually isn't and I can't understand why, but to my knowledge, unless I'm wrong the USB transfer speeds can fluctuate depending on processing power, so wi my MBA it might be fairly slow if I watch a movie and browse Safari as well, I might try hooking it up before I go to bed and see if it has any effect, thanks for the advice :)
     
  12. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #12
    Yeah seriously get over yourself. You would sh&t at the size of my CD collection. I have over 32K worth of songs.

    Yes you can stop it. Hit the little "X" in the window that shows what is playing.

    However when you load up some more songs it might kick off again. I haven't looked at iTunes 10 yet but I know there used to be a check box that says determine gapless playback etc.
     
  13. skate71290 thread starter macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #13
    That option to Enable Gapless Playback is enabled for all my songs and disabling it means it has to process all the songs again lol, I'm just going to keep working my way through them, just cancelling it when I need to use my laptop, I cannot wait for the new i7 MacBook Air :rolleyes: ;) :D
     
  14. jazzmsngr macrumors newbie

    Joined:
    Sep 20, 2010
    #14
    I am having the same issue, however, I do not have a time capsule, but just a simple internal drive networked (via a windows workgroup) that is sharing the music. I load the music (via wifi, or ethernet) and all goes fine, except processing album artwork, or determing gapless playback, takes FOREVER....as in I let this run for two straight days, and still it did not finish. Any help would be GREATLY appreciated, BTW, I am running a BRAND NEW Macbook Pro, I5, and I get this issue, ONLY with that machine. When I try the same exact scenario with my POS Dell Inspiron 8600 (windows xp - PENTIUM 4!) I HAVE NO ISSUES, even on wifi, gapless, and album artwork, Zip right through....on a library with 160GB of music......and BTW.......

    Just because someone has a large music library does not mean they are a pirate, I happen to collect and encode VINYL (of which I have over 1000 lps), I use them for DJ mixing, I also am a musician and have been collecting music for 25 years! I never toss anything, I archive it. I also have about 30gbs of stuff that is MY OWN COPYRIGHT WRITTEN MUSIC!!!! That is over 1000 tracks right there, just from live shows, recordings, and other scratch ideas.....

    Also, I have a wife, and (being a musician & DJ) I have probably gotten more P@$$Y than most people on this site. My Wife understands completely why I do what I do, she does not think its sad, especially since a lot of my time has been rewarded with you know....A PAYCHECK......so just because you are a SAD person, and you might know a bunch of other SAD people (like ones who condemn people on chat boards) Does not mean we all are.
     
  15. dknightd macrumors 6502

    Joined:
    Mar 7, 2004
    #15
    There seems to be a problem with itunes 10 and network drives. Search the apple forums. No solution yet (except roll back to itunes 9.2.1) that ive seen
     
  16. Mister9 macrumors regular

    Joined:
    Feb 11, 2008
    #16
    I have the same problem, and my music is on a network drive. Its pretty annoying that I have to filter thru so many irrelevant posts on this thread... Also, I'm on a Macbookpro6,2 i7 w/ 8 GB RAM so its not your computer.
     
  17. rednaxela0 macrumors newbie

    Joined:
    Jun 7, 2011
    #17
  18. Cole JM macrumors regular

    Joined:
    Mar 13, 2011
    #18
  19. Mike's macrumors newbie

    Joined:
    Mar 17, 2012
    #19
    found an answer to this on mikevee website. Just only to bypass this : select all your songs in your iTunes library --> in the shortcut menu choose "get info" --> find the tab that has gapless playback on it --> check it and select no.

    His website said not to upgrade after iTunes 6. I think that was proposterous.

    I just did this and it looks like it worked.

    Doesn't solve the issue if I wanted to have gapless playback though.
     

Share This Page