iTunes does not have write access?

Discussion in 'Mac Apps and Mac App Store' started by ccnp11, Mar 21, 2012.

  1. ccnp11 macrumors newbie

    Joined:
    Nov 26, 2011
    #1
    Well, first of all, bollocks. Itunes is wrong. I can not download anything from the app store as the message that iTunes does not have write access to the iTunes, or a child thereof, directory. These are in my user folder so running itunes with my user account should be enough...

    But just to be thorough I ran #chown -R (with appropriate options) to the iTunes directory. This did not solve it. Then I ran #sudo chown -R [ops] and still no luck. Then I used chmod to add '+w' to the directory, then chagned toe mode to 775, and then 777....all with no success. Resinstalled iTunes...still getting the error.

    Any thoughts?
     
  2. everygeek macrumors newbie

    Joined:
    Mar 22, 2012
    #2
    Shutdown and than boot back up.

    I get this error whenever I do a restart instead of a shutdown/start. Not exactly sure what's causing it and that's the solution that works for me.

    Another thing you may want to check out is open console and than open iTunes and see what errors pop up when you open it. It should tell you which directory it's having a problem with.
     
  3. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #3
    Are you using Lion?

    Try booting CMD+R to get into recovery. Pull down utilities menu to open terminal.

    Type "resetpassword" in terminal.

    Select your user account and hit reset home home directory. Reboot and see if that helps.
     

Share This Page