iTunes doesn't group by Album name

Discussion in 'Mac Apps and Mac App Store' started by Tex-Twil, Nov 17, 2008.

  1. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #1
    Hi,
    I've just imported some songs to iTunes and they have all the same ID3 tag for "Album". iTunes can see this Album name but it doesn't group them in the Album view. I see seven times the same album ....

    If I edit the the album name via iTunes and set the same album name again, it will group them.

    What's going on ?

    Thanks,
    Tex
     
  2. Applepwns macrumors member

    Joined:
    Aug 9, 2008
    #2
    I have this same problem. I have been looking for a fix for several weeks now trying to get my library perfect.
     
  3. Galley macrumors 65816

    Galley

    Joined:
    Mar 24, 2008
    #3
    Make the sure the same thing is entered in the "Album Artist" field.
     
  4. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #4
    I three have this problem, though with my problem I have, for example, a 10 song album with 9 songs showing up together in album view, and 1 song by itself. I have tried everything to get these files to match up but no go. I honestly think its iTunes screwing up, because whatever suggestions someone has on fixing it I've tried.
     
  5. ravenousllama macrumors member

    Joined:
    Nov 1, 2008
    Location:
    Chicago
    #5
    I get this problem with iTunes occasionally too. The solution I've found is to edit the iTunes tags so that the Album Artist is set the same as the Artist. This almost always groups them as one album.
     
  6. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #6
    1. Select all the songs of the album, press CMD-I so get the info-window, set the album artist field.

    2. Then select the options-tab on the right (inside the info-window), select "part of compilation", hit ok.

    3. Press CMD-I so get the info-window again and deselect "part of a compilation", hit ok.

    Strangely enough this worked for me. :)
     
  7. cdcastillo macrumors 6502a

    cdcastillo

    Joined:
    Dec 22, 2007
    Location:
    The cesspit of civilization
    #7
    It does not work for me. I need to enter the same album artist, then delete it. Why?, I dont know
     
  8. cdcastillo macrumors 6502a

    cdcastillo

    Joined:
    Dec 22, 2007
    Location:
    The cesspit of civilization
    #8
    ++

    This only works when the artist is different on the same album, not when the album and the artist is the same in every song in the album. Try the album artist suggestion.
     
  9. siriwe macrumors newbie

    Joined:
    Sep 28, 2009
    #9
    That worked!

    Been having the same problem, but this recipe helped. Thanks!
     
  10. HBOC macrumors 68020

    Joined:
    Oct 14, 2008
    Location:
    SLC
    #10
    Sometimes I have this problem.
    I will do two things that WILL ALWAYS WORK! the first example is what i prefer.

    #1. I will delete the artists name and album (all the artist info) after going to "get info" on the song. I will then re-type the name. iTunes will "automatically" fill in the artist as you type. I will just type in the artist name, even if it does auto-fill in. Same goes for the album.

    I will then hit ok. Sometimes (well most) it will go from two album arts to one. If that doesn't work, I will re-type the info, and then click "part of a compilation". I will do this will all the songs in the album. Kinda redundant, but it will work.

    I have almost all of my music (all 8000+ songs) organized perfectly :) Too bad i can't get paid for this!
     
  11. FBR macrumors newbie

    Joined:
    Jun 14, 2009
    #11
    Holy ****, thank you. Been trying everything for the past thirty minutes and this finally worked.
     
  12. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #12
    :) Glad it worked for you. It seems as if it doesn't work for everyone though.
     

Share This Page