iTunes Error 17 Fix

Discussion in 'iOS 8' started by Aaleck, Sep 10, 2014.

  1. Aaleck macrumors 6502a

    Aaleck

    Joined:
    Oct 11, 2007
    Location:
    Michigan, USA
    #1
    I've been searching the site and haven't found a solution to this problem. Problem started with me using Yosemite and iTunes beta and the iPhone would cause iTunes to crash. Installed Xcode and everything seemed to work fine until I tried installing the GM again. I received the "error 17" code. I used Tiny Umbrella to get my phone out of the restore process. Here's the solution to get rid of the error 17 on a mac.

    1. Go to terminal and type in "sudo nano /private/etc/hosts"
    2. Type in password
    3. Once it's loaded use the arrow key to go to the very bottom and delete the entire "*.apple.com" entry
    4. When finished, hit Control+O followed by "enter" to save changes, then hit Control+X to exit

    Then you're done! This worked for me. Do this at your risk. It may or may not work for everyone.
     
  2. ProphetX macrumors 6502

    Joined:
    Feb 8, 2011
    #2
    Im having the same problem but I’m I’m confused by #3. Can you clarify? Delete the entire line that has apple.com in it or just delete everything in quotations "*.apple.com”

    My entry does not have a * in it. It reads “gs.apple.com"
     
  3. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #3
    * is a wild card
     
  4. ProphetX macrumors 6502

    Joined:
    Feb 8, 2011
    #4

    So do i delete the entire line or......
     

Share This Page