iTunes error after install.....

Discussion in 'iPhone' started by Mr. Giver '94, Jun 17, 2009.

  1. Mr. Giver '94 macrumors 68000

    Mr. Giver '94

    Joined:
    Jun 2, 2008
    Location:
    London
    #1
    So I installed 3.0, but now I'm unable to access the phone info page in iTunes. It gives me Unknown Error (-4)


    Any way to fix this... ???:confused:
     
  2. timmciglobal macrumors member

    Joined:
    Jun 3, 2008
  3. Serial macrumors newbie

    Joined:
    Apr 17, 2009
    Location:
    Kastanienbaum, Switzerland
    #4
    Some **** just deleted my ****ing thread...

    I am getting the same problem says cant connect to itunes store or whatever...

    btw to the **** who deleted my thread **** you bitch!
     
  4. Kethax macrumors newbie

    Joined:
    Oct 27, 2007
    #5
    I've just tried, had this problem but on about the 12th go it worked!
     
  5. Roessnakhan macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    ABQ
    #6
    By your post I can't imagine why...
     
  6. Jason S. macrumors 6502a

    Joined:
    Jul 23, 2007
    Location:
    Pennsylvania
    #7
    Could it be that a bunch of people are trying to download at the same time and your IPSW files are corrupted?
     
  7. Steve1496 macrumors 6502a

    Steve1496

    Joined:
    Apr 21, 2004
    #8
    Same here and also going on with other family members who have iPhones. Apple seriously needs to get this upgrade process down better. It seems every time there is an update or launch, there are iTunes Store problems.

    You would think they would be able to figure this out by now.

    Steve
     
  8. patton02 macrumors newbie

    Joined:
    Jun 17, 2009
    #9
    This is bull ****. Ive reinstalled. Cant restore or anything. Did you have to have the latest firmware 2.2.1?
     
  9. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #10
    Got the same error message.

    From past experience (Jailbreaking) I connected my "disabled" iPhone to another Mac and it "activated" just fine.
     
  10. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #11
    I smell a ban coming your way.
     
  11. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #12
    i'm on about the 30th after many iPhone reboots+MacBook reboots.
     
  12. trendkiller macrumors member

    Joined:
    Dec 14, 2008
    #13
    Me too!

    I was told to force a restore by apple support...By connecting the iphone to itunes, hold home and on/off switch until itunes refreshes, then click restore iphone...which it is doing now!

    Doing this will lose any data that isn't backed up....

    Failing this the apple customer care told me to turn it off then on again and try again tomorrow!
     
  13. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #14
    Just give it a few minutes...servers are getting hit hard. I got errors for about 10 minutes but just got it activated :).

    Time to play...
     
  14. Kethax macrumors newbie

    Joined:
    Oct 27, 2007
    #15
    I say 'worked'... it activated the phone, although as such I can't sync the phone with itunes as it didn't reach the registration screen. It's surely a server issue.
     
  15. blueharvester macrumors regular

    Joined:
    Oct 22, 2007
  16. sammich macrumors 601

    sammich

    Joined:
    Sep 26, 2006
    Location:
    Sarcasmville.
    #17
    Select something other than your iPhone, then click your phone again. Let it try to connect.

    If it fails again, try again. I think it worked on my 5th go.
     
  17. Kevin6432 macrumors newbie

    Joined:
    Feb 20, 2009
    Location:
    Dallas
  18. cjwosbon macrumors member

    Joined:
    Feb 11, 2008
  19. Jiddick ExRex macrumors 65816

    Jiddick ExRex

    Joined:
    May 14, 2006
    Location:
    Roskilde, DK
    #20
    Phew. Reading this makes me realize it's a server issue.

    No reason for me to keep hanging around work here anymore then...
     
  20. cjwosbon macrumors member

    Joined:
    Feb 11, 2008
    #21
    Working now, if its any help I disconnected the iPhone, closed iTunes, restarted and it worked first time - may have been luck but worth trying!!
     
  21. ddisoul macrumors newbie

    Joined:
    Jun 17, 2009
    #22
    same here and loosing my time instead of being outside with a nice weather in montreal...
    damn apple come on wake up!!!
     
  22. Roessnakhan macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    ABQ
    #24
    Mine took about 20 tries but eventually went through.
     
  23. iRob213 macrumors member

    iRob213

    Joined:
    Sep 25, 2008
    Location:
    Southern Indiana
    #25
    Well...I figured I'd be the only SOB in America trying to log into iTunes:p
     

Share This Page