iTunes Error

Discussion in 'Mac Apps and Mac App Store' started by CPGuru, Jan 22, 2008.

  1. CPGuru macrumors newbie

    Joined:
    Dec 25, 2007
    #1
    I tried renting Transformers and when the download was complete, an error occured and the movie won't play. And the transaction still took place.

    The error read: We could not complete your iTunes Store request. An unknown error occured (5103).

    Thanks
     
  2. Zarchanalin macrumors newbie

    Joined:
    Apr 20, 2008
    #2
    Fixing 5103

    Okay, so the thing that causes this error is an incorrect time stamp on your computer when you try to perform a transaction with the iTunes store, most commonly with rentals. It's believed that this was instituted due to the fact that people were resetting their clocks into the future when they first played rentals, then resetting to normal time. This gave them years to watch their rental.

    Fortunately, all that should be required is simple. Resetting your clock to internet time/automatic time and reauthorizing your account is all that you are supposed to have to do, but that, many times, does not work. If it does not, you need to delete the folder "SC Info". The following article has the information down in it's second part: Apple iTunes Requires Constant Authorization and Doesn't Play Downloaded Content

    Hope this helps you out.
     
  3. btpyper macrumors newbie

    Joined:
    Feb 15, 2009
    #3
    I have kinda the same deal. i rented four movies from itunes and it finished and the it poped up with we could not complete your itunes store request. " An unknown error occurred (-42110). So i spent quite a bit of money just to be wasted. PLEASE HELP
     
  4. bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #4
    did you try the suggestion explained in this thread?
     
  5. anabellani macrumors newbie

    Joined:
    Aug 5, 2010
    #5
    iTunes error

    I rented 4 movies and when it comes to"processing files" it pops: we could not complete your iTunes request, an unknown error occurred (5103). There was an error in the iTunes store, please try again later. I was charged for the movies and can't see them. It seems that I'm not the only one....... Please HELP!!!!!
     
  6. JamesR404 macrumors newbie

    Joined:
    Oct 3, 2011
    #6
    Tried deleting "CS info" ?

    You can also try to delete the "CS info" directory in Itunes, I was lucky with that one.

    Another suggestion I read elsewhere for this error is to update Itunes to the latest version.

    .... For me Itunes is a very annoying user experience (low volume, issues playing om my HD monitor, to various bugs from time to time), I think they'll only fix these things when a big competitor comes along and makes it easy to rent many popular movies.
     

Share This Page