iTunes Errors 21, 2001, 1600....Please Help!

Discussion in 'Jailbreaks and iOS Hacks' started by rsands, Feb 10, 2009.

  1. rsands macrumors newbie

    Joined:
    Feb 10, 2009
    #1
    Hi Guys, I have spent the last 30 or so hours trying to jailbreak my iPhone 3G. I have had success before, but I can’t restore with a custom firmware, if I don’t get error 21 (unknown) I get error 1600 (unknown). And if I enter DFU mode using Pwnage Tool, iTunes gives me error 2001 (the iPod cannot be identified). I have followed multiple directions and learned that 10.5.6 breaks the jailbreak (no, I’m not on a new MBP), and I have followed the solution out of it on multiple websites, including the Dev Team. I am almost sure that the custom firmware I have made is fine, it’s just that iTunes won’t accept it. Also, my phone use to be jail-broken but I accidently restored it with the wrong firmware…now i’m screwed. Also, I do not want to unlock anytime soon...just jailbreak and I understand that QuickPwn will only update your jailbreak. Thanks so much! Please help…
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    I think you said it yourself, you restored the wrong firmware. Not looking good, but have you tried DFU mode and restoring the correct one? If so, are you using a powered USB hub? I wouldn't recommend editing your USB kexts.
     
  3. rsands thread starter macrumors newbie

    Joined:
    Feb 10, 2009
    #3
    Sorry...when I said "restored with the wrong firmware" I meant that I restored using Apple's firmware, not the Pwnage firmware. My point being that my phone is NOT currently jailbroken. THANKS in advance for support...I appreciate it.
     
  4. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #4
    Ok, so are you using a machine that you did not do the USB kext edits on, and then using a USB powered hub instead?
     
  5. rsands thread starter macrumors newbie

    Joined:
    Feb 10, 2009
    #5
    Sorry for the confusion...

    I have an un-jailbroken iPhone 3G
    I am using Mac OS X 10.5.6
    I have made the .kext file edits
    I am using the latest version of iTunes and Pwnage Tool
    I have tried using a USB hub with no sucess

    Thanks for all the help!

    -Rafael
     
  6. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #6
    Being that you made the USB kext edits, you needs to use the hub on another machines that isn't hosed. :)
     
  7. rsands thread starter macrumors newbie

    Joined:
    Feb 10, 2009
    #7
    Oh...I tried that too. I even tried making the kext edits on a different computer and it didn't work.

    Thanks....
     
  8. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #8
    I actually ran into those errors for some reason, but all I did was restore with itunes official apple software and then stop right at the at&t verification window.

    So I went back to the pwnage tool and follow the instruction once again, and when it asks if it has been jailbroken before I said no

    Then I got back to the itunes window and use the pwnage software by holding down the option key as usual, and it worked :)


    I also have a mac, but I didn't do the text edit thing. I just followed the instructions on the iphone dev site about the sofware you need in order to disable the USB problem
     

Share This Page