itunes firewall issue

Discussion in 'macOS' started by brentg33, Apr 7, 2010.

  1. brentg33 macrumors 6502a

    Joined:
    Mar 5, 2007
    #1
    Ever since upgrading to itunes 9.1, every time i open it, the firewall prompts me to allow or deny itunes. I have tried going into security in sys pref and deleting itunes from the list of allowed apps and re-adding, but still it keeps asking me every time...does anyone have any ideas? i am running SL 10.6.3
     
  2. Lukasmacy macrumors member

    Joined:
    Apr 7, 2010
    Location:
    Britian
    #2
    I'm having the same problem in Leopard every time I open iTunes it pops up, the same for Eyeconnect except that pops up 3 times every time I log in.
    I have removed it from the firewall allow list and accepted it when it pops up but the same happens after restart.
    Anyone ????
     
  3. Lukasmacy macrumors member

    Joined:
    Apr 7, 2010
    Location:
    Britian
    #3
    Open terminal and enter "codesign -v /Applications/iTunes.app"

    If the output of this command is anything but "Valid on disk", uninstall iTunes and reinstall it. This fixed my problem.
     
  4. brentg33 thread starter macrumors 6502a

    Joined:
    Mar 5, 2007
    #4
    Thanks. What would be the easiest way to uninstall and reinstall iTunes while preserving your music library?
     
  5. 2Bad4U macrumors member

    2Bad4U

    Joined:
    Oct 31, 2009
    Location:
    Atlantic Canada
    #5
    I'm experiencing the same issue with iTunes and my firewall.
    I tried the above command from the terminal window with the following response...

    "/Applications/iTunes.app: a sealed resource is missing or invalid"

    Is this common with others?
     
  6. brentg33 thread starter macrumors 6502a

    Joined:
    Mar 5, 2007
    #6
    that is the same response i had...i guess we need to uninstall and reinstall?
     
  7. Lukasmacy macrumors member

    Joined:
    Apr 7, 2010
    Location:
    Britian
    #7
  8. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #8
    Thanks a lot for the uninstall-reinstall tip, worked perfectly, thanks very much :)
     

Share This Page