iTunes for Windows 7 - 64 bit ??

Discussion in 'Windows, Linux & Others on the Mac' started by fab5freddy, Oct 30, 2009.

  1. fab5freddy macrumors 65816

    fab5freddy

    Joined:
    Jan 21, 2007
    Location:
    Heaven or Hell
    #1
    I am running an Acer Windows 7 Machine PC ( not mac ),
    and cannot seem to find iTunes for 64 bit ??

    Does anyone know where to download iTunes 64 bit for Windows 7 ?

    Thanks!
     
  2. ayeying macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    iTunes 8 and 9 64-bit work great under 7. You just have to select the 64-bit version from the download page.
     
  4. Maserati7200 macrumors 6502a

    Maserati7200

    Joined:
    Mar 17, 2009
    Location:
    11230, Midwood, Brooklyn, NY, USA, North America
    #4
    Wait a minute.. windows gets a 64 bit iTunes and we (OSX users) don't?? What kind of BS is that? :mad: iTunes needs to be written in Cocoa and be 64 bit.
     
  5. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #5
    The services are 64-bit but the application and Quicktime are still 32.
     
  6. fab5freddy thread starter macrumors 65816

    fab5freddy

    Joined:
    Jan 21, 2007
    Location:
    Heaven or Hell
    #6
    The only iTunes 64-bit version i can find is version 8.02 iTunes ?

    How can i get the latest 9.02 ?
     
  7. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #7
    It's right on the main iTunes page.

    [​IMG]
     
  8. heckubiss macrumors newbie

    Joined:
    Nov 1, 2009
    #8
    This is absolute BS.
    it seems impossible to synch Iphone when using Windows 7 -64bit

    There is a known problem with the latest Itunes for windows 64 bit 9.0.25 not detecting Iphone, so the solution is to download Itunes 64 bit 8.0.2

    however when I do that It says Iphone requires Itunes 8.2 or later to synch!!!!!!!!!!!!!!!
     

Share This Page