itunes hangs when connecting classic 120GB

Discussion in 'iPod' started by LedZepp81, Mar 2, 2009.

  1. LedZepp81 macrumors newbie

    LedZepp81

    Joined:
    Mar 2, 2008
    #1
    I have searched this forum and all over the web but can't find any help with this.
    When connecting ipod, itunes hangs and doesn't respond. However, finder can see it and I can access it by clicking on the icon from the desktop. Also I have nothing on the ipod, no music, video, pictures ect.

    I have rebooted, reset, and also put the ipod in disk mode and nothing works. Also I do have the latest version of itunes. This is really driving me crazy, I just don't know what else to do.

    Can anyone give some insight?

    Thanks
     
  2. pakyooh macrumors 6502

    pakyooh

    Joined:
    Jan 21, 2009
    Location:
    California
    #2
    I'm also having the same problem with my 80gb classic. So far my only guess is its because I accidentally dropped it. I successfully restored the ipod by can't sync it.

    I've tried to sync my shuffle and it seems to work.

    Will have apple take a look at my ipod.
     
  3. LedZepp81 thread starter macrumors newbie

    LedZepp81

    Joined:
    Mar 2, 2008
    #3
    Yea, I saw all the post about the 80 GB model having the issue but can't find anything about the 120 GB. This thing is new, bought awhile ago but last night was the first time I went to use it. So it was never dropped or damaged.
    I made an appointment at the local Apple store for tomorrow, we'll see what they say.

    I would like to just exchange it for another one but the problem is I don't have my receipt, how would Apple handle that?
     
  4. rWally macrumors regular

    Joined:
    Sep 17, 2006
    Location:
    Denver, CO
    #4
    Wow, this is really strange. My 160 GB classic just did the same thing. I synced one day and didn't notice that iTunes had wiped it completely clean. When I went to re-sync it didn't even recognize the ipod as being properly formatted. I had to completely restore it.

    It took me about 3 attempts to get all my music back on it too. It kept stalling mid way through my syncs. I finally got everything back on but now I'm scared to try and sync again.
     

Share This Page