iTunes has upgraded beyond my OS and won't work

Discussion in 'Mac Apps and Mac App Store' started by Hoogstraten, Dec 24, 2008.

  1. Hoogstraten macrumors newbie

    Joined:
    Dec 24, 2008
    #1
    Evidently through automatic upgrades my iTunes has upgraded itself to version 7.7.1 - I just tried to open it and got a pop up window telling me that in order to use iTunes I need OS 10.4.9 (I have 10.4.6). How could it have downloaded for an OS that it won't work with? I don't feel like shelling out the bucks for the OS upgrade, and when I tried to install an older version of iTunes, I got another pop up window telling me I couldn't because a newer version was already installed. I'm afraid that if I dump the newer one I'll lose all my tunes.
    Any suggestions?

    Thanks -
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    Update your OS. It's not that hard. And it's freaking free. 10.x.x updates are free. 10.x updates aren't. I take it you haven't updated since you got your machine.
     
  3. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #3
    Updating to 10.4.9 (well actually 10.4.11) is a free software update, not a purchasable upgrade.

    10.5 is a OS upgrade, hope that helps.
     
  4. Hoogstraten thread starter macrumors newbie

    Joined:
    Dec 24, 2008
    #4
    I couldn't find any free upgrades for 10.4.9 - they all wanted money - $449. Where can I find a free one? I googled "free download OS 10.4.9"
     
  5. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #5
    It's in Software update; you don't go BUY it! Apple Menu, Software Update.

    You'll have around seventy updates to apply if you've haven't even run the thing since you got it.
     
  6. Hoogstraten thread starter macrumors newbie

    Joined:
    Dec 24, 2008
    #6
    Thanks, Tallest Ski,
    What can I say - I'm a luddite.
     
  7. ikna macrumors newbie

    Joined:
    Jan 25, 2009
    #7
    Upgrade incompatible with other software....

    It's all well if you don't have other software to be concerned about. The Adobe CS suite won't work either with a later OS than 10.4.6, and I don't have the money to upgrade them. :(

    I have read on another forum that if I install itunes 7.2 (older version), then it will work on OS 10.4.6. Has anyone tried that?
     
  8. ultimateceej macrumors regular

    ultimateceej

    Joined:
    Jul 24, 2007
    Location:
    Texas
    #8
    I'm curious about how many updates you actually did have! :D
     

Share This Page