iTunes Home sharing doesn't work on wireless network

Discussion in 'Mac Apps and Mac App Store' started by rerelease, May 1, 2010.

  1. rerelease macrumors regular

    Joined:
    Jun 8, 2009
    Location:
    eesti
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7D11 Safari/528.16)

    I tried to set up a home share between mine and my girlfriend's MacBooks. It worked okay both ways, but then I disconnected my ethernet cable and the connection dropped.

    I started fiddling around and discovered that home sharing only works as long as any one of the two computers is connected to the router with a cable. The other one can be connected wirelessly. But it won't work if both are wireless at the same time.

    Any ideas as to what's causing it and how to fix it?
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    No, that's incorrect. Homesharing works on all my Macs wirelessly.
     
  3. rerelease thread starter macrumors regular

    Joined:
    Jun 8, 2009
    Location:
    eesti
    #3
    Hence something's terribly wrong my network (presumably, since it doesn't matter which computer is plugged in).
     
  4. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #4
    That was going to be my next question leading on to asking whether the Macs were on the same Airport channel.
     
  5. rerelease thread starter macrumors regular

    Joined:
    Jun 8, 2009
    Location:
    eesti
    #5
    I realised that this problem actually persists for all local networking solutions. Can't share files when both computers are wireless etc.

    Too bad the documentation for my router sucks. Bleh.
     
  6. Ice Cream Man macrumors member

    Ice Cream Man

    Joined:
    Jan 1, 2003
    Location:
    Earth
  7. rerelease thread starter macrumors regular

    Joined:
    Jun 8, 2009
    Location:
    eesti
    #7
    It's a TrendNet TEW-651BR and unfortunately I have no idea how to.
     
  8. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #8

Share This Page