iTunes Home Sharing & iPhone Remote App Problem

Discussion in 'Mac Apps and Mac App Store' started by PJT, Oct 3, 2010.

  1. PJT macrumors member

    Joined:
    Dec 18, 2003
    #1
    I first posted this on the Apple (US) discussion board, but there was not responses, so thought I might try here.

    I have been having this problem for as long as Home Sharing and the Apple Remote for iPhone has been available. I am throwing out to see if someone can help. Here's the background.

    1. One day Home Sharing (iTunes 10.0.1 but also in iTunes 9.x) works, and then a few days later, it will not work. A few days later, it works again.
    2. When Home Sharing stops, I get the messages about Firewall settings, but I have made no changes to any settings. I am using 10.6.4. I have tried turning off the Firewall and restarting the computer, but that did not work. I currently have the Firewall on and it is set to allow incoming connections to iTunes.
    3. When Home Sharing stops, Apple Remote on my iPhone also no longer connects to iTunes.
    4. 2 iPhones can still connect to my other computer running Tiger. It is always the Snow Leopard computer that has the connection issue.
    5. My IPv4 addresses did not change on any device.
    6. I have IPv6 turned to Off.
    7. All my devices are running on the same WiFi network. No other connections are effected, and the iPhones connect to the Tiger computer with no problem.
    8. I have tried uninstalling iTunes, and removed all iTunes related files as outlined on the Apple support page. After a fresh install, Home Sharing still did not work.
    9. I have tried uninstalling the Apple Remote App on my iPhone, but it did not work.
    10. When Home Sharing Stops, no iPhones can be paired to iTunes to be able to use Remote. I enter in the number, it spins, beeps and asks for the numbers again.
    11. I have tried renaming my iTunes library.
    12. Restarting the computer does not change anything.
    13. I have not changed any network settings.
    13. Mysteriously, for no apparent reason, Home Sharing and the Remote will start working again at some point.

    So there is some sort of connection issue happening that is beyond me. It is only in iTunes on my 10.6.4 computer. Only iTunes is affected. Time Capsule is backing up. All other connections to the internet work fine. Sync is never interrupted.

    I believe someone out there has the answer! Genius, help me!

    Thanks in advance for reading and any help that can be offered.
     
  2. nicoaznar macrumors newbie

    Joined:
    Oct 30, 2010
    #2
    I have the same issue. actually, when it doesn´t work, try disabling home sharing in Itunes and enabling again and you´ll see that the device (iphone or ipod) will find the library again...

    it´s obvously a bug.
     
  3. benposch macrumors newbie

    Joined:
    Jun 2, 2011
    #3
    in case you haven't figured it out, this might be your problem. do you have more than 1 network that you connect to with your iphone? for instance, i have a guest network, and my phone knew both of them, so it would switch to the guest network if the signal was stronger. as soon as i forgot the guest network in my iphone's wifi settings, it always connects.

    i really felt stupid when i realized.
     
  4. ApfelStrudel, Jun 4, 2011
    Last edited: Jun 4, 2011

    ApfelStrudel macrumors newbie

    Joined:
    Jun 4, 2011
    #4
    Remote: wireless vs. wired

    Over here also a few problems with the Remote app on my Touch.
    I would like to use it for controlling iTunes which controls my Denon AVR. My PC and AVR are both wired connected to my LAN and both are working great. The Touch has a wireless connection obviously. Is it possible to let these three work together in this particular setting? I can't find the correct settings. If there is one.

    When I connect my PC wireless, I can control iTunes with my Touch but then iTunes can't find my wired AVR anymore... To make the AVR also connecting wireless isn't really an option.

    Does someone know the answer to this annoying problem? Thanks in advance!
     

Share This Page