itunes / i touch

Discussion in 'iPod touch' started by garrybr, Nov 23, 2010.

  1. garrybr macrumors newbie

    Joined:
    Nov 23, 2010
    #1
    i recently connected my itouch to itunes and it came up with a upgrade to version 4, i downloaded this but the itouch will not work with my version of itunes now. I have tried to download the itunes upgrade version 10.1 but it comes up with an error everytime it tries to download and now my itouch went connected by usb shows a picture of a usb lead and says it is not compatiable with the version of itunes. HELP Please
     
  2. eddy2099 macrumors member

    Joined:
    Sep 27, 2010
    #2
    Which generation of the iPod Touch do you have ?
     
  3. garrybr thread starter macrumors newbie

    Joined:
    Nov 23, 2010
    #3
    version 2 i think i will have to check when i get home approx 18 months old
     

Share This Page