iTunes import songs as albums

Discussion in 'Mac Apps and Mac App Store' started by HE15MAN, Nov 7, 2010.

  1. HE15MAN macrumors 6502a

    HE15MAN

    Joined:
    Sep 3, 2009
    Location:
    Florida's Treasure Coast
    #1
    Any idea why iTunes is importing a few cd's I have where each song is its own album and not grouping the albums together?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Probably because either iTunes isn't reading the metadata correctly or the metadata was written to the file incorrectly in the first place.
     
  3. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #3
    Try selecting all the songs from one album, getting info on them as a group (key Command I), checking whether they're tagged as being part of a compilation (under options) and if so, unchecking it. Then reselecting them and checking them as a compilation again.

    Also, if the songs have various artists, maybe featured vocalists or MCs, then you may have to ensure that an Album Artist is also tagged for each song. The last major update of iTunes changed some things about tagging that I can't get to replicate consistently, so don't worry if it's driving you insane as well.
     
  4. HE15MAN thread starter macrumors 6502a

    HE15MAN

    Joined:
    Sep 3, 2009
    Location:
    Florida's Treasure Coast
    #4
    So I guess the only way to fix it is import a cd at a time, and then manually change the information of each song?
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    Make sure the Album and Album Artist tags are filled in and identical on all tracks. You can do this on an entire album at a time, not individual tracks.
     

Share This Page