iTunes installing problem.

Discussion in 'Mac Apps and Mac App Store' started by surukai12, Jul 24, 2009.

  1. surukai12 macrumors newbie

    Joined:
    Jul 6, 2009
    #1
    When i tried to install iTunes 8.2.1 it gives me the error

    Module C:\Program Files\iTunes\iTunesMiniPlayer.dll failed to register. HRESULT -2147023782. Contact your support personnel.

    Then when i pressed ignore it says

    Service 'iPod Service' (iPod Service) failed to start. Verify that you have sufficient privileges to start system services.

    Please help!!
     
  2. surukai12 thread starter macrumors newbie

    Joined:
    Jul 6, 2009
  3. firecrasher macrumors member

    firecrasher

    Joined:
    Oct 15, 2008
    Location:
    Baltimore
    #3
    I've got it too when I try to open iTunes.... and my virus scanner is saying it's a Trojan. I've tried repairing... uninstall...reinstall...

    here are some screenshots.

    Save us, MacRumors!!!
     

    Attached Files:

  4. gowanis macrumors 6502

    Joined:
    Sep 22, 2007
    #4
    I think its a problem with AVG Anti-Virus (a false positive). Try adding your iTunes path to the AVG exception list.
     
  5. firecrasher macrumors member

    firecrasher

    Joined:
    Oct 15, 2008
    Location:
    Baltimore
    #5
    I already uninstalled iTunes so I'm not sure how that would work. I disabled AVG and tried another install, but I have the same H-2147023782 error message.
     
  6. AeroLancaster macrumors newbie

    Joined:
    Aug 12, 2008
    #6
    I'm experiencing the exact same problem. iTunes has been rendered impossible to open for me. AVG is going crazy and keeps saying that several of my iTunes files are trojans. I tried uninstalling and reinstalling but it's not working at all. This all started when I tried opening a QuickTime movie... :confused:
     
  7. firecrasher macrumors member

    firecrasher

    Joined:
    Oct 15, 2008
    Location:
    Baltimore
    #7
    There's a 19 page thread on the Apple forums about this... it's AVG. I linked to it in the previous thread:

    http://discussions.apple.com/thread....92831&tstart=0

    A couple minutes ago uninstalled everything Apple-related (and downloaded iTunes but didn't reinstall yet), uninstalled AVG, rebooted, installed iTunes, and downloaded and installed AVG.

    So far, so good. I also added my Program Files\iTunes\ to the exceptions list. Hopefully this will work. I'll keep you posted.
     
  8. surukai12 thread starter macrumors newbie

    Joined:
    Jul 6, 2009
    #8
    Okay i uninstalled AVG and its working 100% now! Ty.

    I will try reinstalling AVG later and see if it works..
     
  9. firecrasher macrumors member

    firecrasher

    Joined:
    Oct 15, 2008
    Location:
    Baltimore
    #9
    Still going well, surukai? I haven't had any problems so far.
     

Share This Page