iTunes & iPhoto quited unexpectedly

Discussion in 'MacBook' started by getfor80, Feb 15, 2012.

  1. getfor80 macrumors newbie

    Joined:
    Feb 15, 2012
    #1
    I need help for my 1st gen. MBA. During I sync-ing my iPhone4 with the iTunes also in the process of upgrading to 10.5.3, it prompted me to restart the system and I pressed the button. After the restart, the iTunes and iPhoto could not launch properly. They simply gave me a pop up box stating that iTunes/iPhoto quit unexpectedly. Here is an extract of the message:-

    Process: iTunes [663]
    Path: /Applications/iTunes.app/Contents/MacOS/iTunes
    Identifier: com.apple.iTunes
    Version: 10.5.3 (10.5.3)
    Build Info: iTunes-10530301~1
    Code Type: X86 (Native)
    Parent Process: launchd [117]

    Date/Time: 2012-02-15 22:07:28.050 +0800
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6

    Interval Since Last Report: 966 sec
    Crashes Since Last Report: 13
    Per-App Crashes Since Last Report: 2
    Anonymous UUID: F154F626-0EFE-4307-9872-BE92D476028E

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf7ffffc
    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Thread 0 Crashed: Dispatch queue: com.apple.main-thread
    0 libobjc.A.dylib 0x9296699a classHash + 18
    1 libobjc.A.dylib 0x9296642e NXHashGet + 32
    2 libobjc.A.dylib 0x92966cd4 look_up_class + 134
    3 libobjc.A.dylib 0x929672eb connect_class + 112
    4 libobjc.A.dylib 0x9296731e connect_class + 163

    I tried a number of suggested solutions based on other previously forum discussions such as deleting .plist files and removing iTunes and reinstalling it but they did not work.

    Could someone give me some advice what should I do? I would very much appreciate!!:)
     
  2. getfor80 thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #3
    I tried this too but I dont know why I could not open a new account successfully. After i clicked the newly created account icon, the galaxy wallpaper appeared without any apps icons for over 15mins. Looks like the system hang.
     
  3. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    Do you mean, that the Dock did no appear?
    [​IMG]
    If so, what if you press CMD+OPTION/Alt+D to make the Dock (dis)appear?
    Can you browse the Applications folder (CMD+SHIFT+A) or use Spotlight?
     
  4. getfor80 thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #5
    Thx Sim. You are right. The Dock was not there and the Cmd+opt+d or the application folder shortcut have no use.
     
  5. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    "Was" or "is"?
    Anyway, since you have 10.6, you could reinstall it and see, if that works. None of your personal data will be deleted, just files, that are corrupted will be replaced. Maybe that works.
     
  6. getfor80 thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #7
    Yes it 'is' not there. You are saying removing the snow leopard and reinstall it without losing the personal files? Please let me know how just briefly. Do i need to back up the whole hard drive first or by piecemeal for music, photo, mail, etc.?
     
  7. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #8
    It is always a good idea to backup your HDD before a reinstallation, be it via Time Machine or CarbonCopyCloner.

    Anyway, to do a reinstallation of Mac OS X 10.6 Snow Leopard just insert the DVD and follow the instructions presented to you on your screen, just make sure, you DO NOT use Disk Utility to wipe your HDD.
     
  8. getfor80 thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #9
    Sim, thx a lot for your advice. The reinstallation solves the problems. Now the iTunes works again. I also reinstalled the iPhoto using the disks come with my MBA. It also back to normal now. Thx very much. You are awesome!!
     

Share This Page