iTunes is being very slow

Discussion in 'Mac Apps and Mac App Store' started by jonat8, May 29, 2005.

  1. jonat8 macrumors regular

    Dec 17, 2004
    United Kingdom

    Lately I've noticed iTunes being very slow. When I try and scroll up and down my library with the mousewheel every so often it keeps beachballing for a few seconds. When I'm playing tracks sometimes the elapsed time counter cuts out for a few seconds and then catches itself up. If iTunes is in the background and I click it to bring it to the front it'll often beachball for a few seconds and then bring itself to the front eventually. It never used to be like this!

    It's also taking ages to quit - a good 10-15 seconds for the arrow icon in the dock to disappear once I "quit" iTunes and the window closes.

    My music never skips while it beachballs, it keeps playing - it's just the UI that locks up.

    My library is close to 14,000 tracks - could this be having anything to do with slowing it down, having to read the library data in? My music is stored on a mixture of internal hard drives, USB2 drives and network drives.

    I'm running iTunes 4.8 on Tiger - specs are in my signature. Any suggestions for getting it to speed up are welcome although if it is the libary size there isn't much I can do about it I guess!

    One other problem I'm having is that it starts up whenever I start the computer up. I can't seem to stop it doing that. In my "Login Items" preference area there is just ".VirexLogin" and "iCalAlarmScheduler" - nothing to do with iTunes i guess!

    Any advice appreciated because this slowdown is really getting on my nerves! I also want to point out that it happens even if iTunes is the only application running.

    Ta :)
  2. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    It's starting up automatically probably because you've got the iTunes widget on. Turn it off and it won't start up on its own.

    General slowdown - not sure. But it might be down to Virex; it doesn't play nicely with Tiger. You need to uninstall that. You can do this by using the de-installer bundled with Virex. Or Google and find the script that you need to do so.
  3. ITASOR macrumors 601


    Mar 20, 2005
    Uhhh yeah get rid of virex ASAP. And the script that doesn't come with Virex doesn't work on half the computers I tried it on. Just see if you can download Virex on P2P just to use the uninstaller. Yes I know, that's wrong, but who wants to buy it again just to uninstall it? That's only if you deleted the installer like me. :rolleyes:
  4. mammal macrumors newbie

    Jul 24, 2002
    Norway, Oslo
    Exactly same here. 6500 songs, on a PM G5 2*2GHz, 2,5 GB RAM. Mac OS X 10.4.1 iTunes behaves slowly, not at first, but after jumping in and out of programs, it is just like you say, slow in the interface. Like: scrolling, or switching between genres og artists. It lags, it never did before Tiger.
  5. bmelon macrumors newbie

    Feb 3, 2004
    possible solution

    I found this in a random message board through google: try turning off "Live Updating' in all your smart playlists. I've got a PB 1.33 with 768mb ram and 9300 songs on an external firewire drive. I was getting tons of beachballs everytime I added songs, deleted songs, or had itunes in the background. After around 400 clicks to turn off 'Live Updating' in all those playlists, itunes seems much more responsive. No beachballs yet.
  6. thorninc macrumors newbie

    Jan 3, 2008
    Re: possible solution

    Holy moly! Thank you so much for posting that! You just put some step back into my iTunes! :D

    Who needs live updating, anyway? ;)

    - Anton

Share This Page