iTunes is horrible - help please?

Discussion in 'Mac Apps and Mac App Store' started by Rocco83, Oct 3, 2011.

  1. Rocco83 macrumors 6502

    Jul 3, 2011
    Ok so I have a 3TB time machine to house all of my media, which current is roughly 700 DVDs and 3500 songs. I have 2 ATV2s hooked up on my network and I have an iMac I use as my iTunes server. Being that I have over 2TB of media I don't want it to clog up my iMac's HDD so I house it on the time machine and point my iTunes media folder location to the folder on my time machine, but after a restart of my computer or iTunes it tries to redirect everything to the default folder it wants to create in my local music folder. It takes hours to try to reload everything back onto iTunes from my time machine and I am really getting tired of having to do so.

    I've read through post after post on the interwebs about fixes for this and it seems this has been a problem with iTunes for the last 6 years. Is there a definitive fix for this as Apple customer support says uninstalling iTunes and reinstalling it will fix the problem. News flash, it doesn't fix the problem.

    I've tried unchecking the Keep iTunes Media folder box as some have suggested works, i've kept it checked. I've moved the original created iTunes folder to my external and created an alias for it in my original folder and it didn't work. I'm really starting to run out of options and cannot fathom why Apple wouldn't have fixed a legacy issue like this.

    Any suggestions, or better yet, a permanent fix??
  2. MacBoobsPro macrumors 603


    Jan 10, 2006
    If i remember correctly where the default library is located you need to get rid of that folder and place a shortcut to your library on the TimeCapsule. So when you start iTunes it then goes to the correct library. Because your TC is sleeping iTunes doesnt see your preferred library and so uses the default library which it can see. With the shortcut, this wakes your TC then iTunes can see it and it should all work however it can take a few seconds for it to be recognised.

Share This Page