iTunes is not doing a full restore from backup

Discussion in 'iPhone' started by DDustiNN, Sep 19, 2014.

  1. DDustiNN, Sep 19, 2014
    Last edited: Sep 19, 2014

    DDustiNN macrumors 65816

    DDustiNN

    Joined:
    Jan 27, 2011
    #1
    I backed up my 5s to both iTunes and iCloud before starting. My 5s is still on iOS 7.

    When I try restoring from iTunes to my new iPhone 6 (specifically choosing the backup time from this afternoon), it seems to still restore from a very old backup (many apps show up with their old iOS 6 icons while syncing). Possibly from an older phone like my 4 or 5. After the restore completes, I am missing quite a few apps, and some apps are very old, like iOS 6 version of Facebook, for example.

    Everything else is up-to-date, like photos, texts, call logs, etc... But why are my apps not restoring?

    I reset and tried restoring form iCloud, but it consistently gives me an error "Cannot restore backup". It will start progressing for a bit but eventually gives that error. A couple times it said it couldn't connect to the server, but most of the time it's just the general error.

    When I plug my 5s into iTunes, it shows 163 apps, and everything is there. I click Sync, and everything finishes. When I plug my iPhone 6 in, there are 99 apps and they are all very old.

    Any ideas on how to force the new apps onto my new phone using iTunes? I have no idea why this is happening and it's driving me crazy...

    This is why I hate iTunes and I always have. It never "just works".
     
  2. DDustiNN thread starter macrumors 65816

    DDustiNN

    Joined:
    Jan 27, 2011
    #2
    Nevermind, I reset and tried iCloud again and that seems to have worked fine this time.

    I still have no idea why iTunes backups won't restore my full apps though so I'd still like to know how to fix that, if anyone knows. Thanks.
     

Share This Page