iTunes keeps erasing my songs, please help

houssein31

macrumors regular
Original poster
Jul 16, 2013
147
0
I have been dealing with issue for so long now, I can't take it anymore. Every single time I sync my iPhone to my Mac it erases about 200-300 songs forcing me to redownlod them all the time. It's really bugging me.

I would simply stop syncing my iPhone to my macs but I only do it so I can get my playlists everywhere..so I need to sync

I'm pretty sure its some option I need to adjust on iTunes (one my Mac) but I just don't jnow)

Can someone please tell me how to fix this??

Thanks
 

BasicGreatGuy

Contributor
Sep 21, 2012
11,666
10,701
In the middle of several books.
ITunes > Preferences > Devices > make sure the box to sync automatically is not checked. When your phone is connected to iTunes and you want to sync music, make sure it is set to sync only the songs that are checked, if that is what you want. That should solve your problem.
 

Consultant

macrumors G5
Jun 27, 2007
13,286
14
"I would simply stop syncing my iPhone to my macs"

Classic user error. The issue seems to be that you don't have the same songs and library files on multiple computers.

There won't be a problem if your library contains the same songs as your iPhone.


I have been dealing with issue for so long now, I can't take it anymore. Every single time I sync my iPhone to my Mac it erases about 200-300 songs forcing me to redownlod them all the time. It's really bugging me.

I would simply stop syncing my iPhone to my macs but I only do it so I can get my playlists everywhere..so I need to sync

I'm pretty sure its some option I need to adjust on iTunes (one my Mac) but I just don't jnow)

Can someone please tell me how to fix this??

Thanks
 

houssein31

macrumors regular
Original poster
Jul 16, 2013
147
0
"I would simply stop syncing my iPhone to my macs"

Classic user error. The issue seems to be that you don't have the same songs and library files on multiple computers.

There won't be a problem if your library contains the same songs as your iPhone.
All my library through all my Macs and idevices are the same
 

GanChan

macrumors 6502a
Jun 21, 2005
588
22
ITunes > Preferences > Devices > make sure the box to sync automatically is not checked. When your phone is connected to iTunes and you want to sync music, make sure it is set to sync only the songs that are checked, if that is what you want. That should solve your problem.
Actually, it looks the sync box in the current version of iTunes does the opposite -- it prevents automatic syncing instead of allowing it. In which case, you would want to make sure it's checked. I guess it depends on which version you're using.