iTunes Library Location Default

Discussion in 'Mac Apps and Mac App Store' started by rayward, Jan 11, 2010.

  1. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #1
    I've recently moved my media to a NAS, to unclog my iMac's HD. Trouble is, iTunes keeps returning the library location to the default. It is frustrating when it puts new content into the old library on the Mac, but even more frustrating when it "loses" all my other media content as this bleeds over to my ATVs.

    Every time this happens, I have to switch the library location back to the NAS, then consolidate to get all the content into the correct library (all of which sends my ATVs into a frenzy of syncing), then clean out the default library location of now-defunct copies of my media.

    Anyone got any ideas how to:

    1) Get iTunes to stick to the NAS library; or

    2) Avoid all the consolidation crap if/when it happens again?

    TIA
     
  2. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #2
    I can't offer you much help, but I can tell you why it was happening in my case. I have a Drobo V2. The Drobo, by design, spins the RAID disk pack down when not in use. This isn't a great problem, except it takes the Drobo about 10-15 seconds to get the disk pack spun back up and ready to go. Every once and awhile, if the Drobo doesn't spin up fast enough, iTunes will get impatient and do exactly what you are describing - jumping back to it's original 'out-of-box' library location.

    It is annoying, and the only solution was to access the Drobo prior to placing new media into iTunes. Strangely enough, since updating to Snow Leopard, I haven't experienced this. I'm not sure if a default time-out setting was changed...

    By the way, this problem will also manifest itself as the dread 'iTunes was unable to play this content' or 'this content is not playable due to being the wrong format' on an AppleTV due to the NAS or DAS not allowing access quickly enough.

    What NAS do you have?

    Good Luck.
     
  3. rayward thread starter macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #3
    I have a Western Digital "My Book". It was a good combination of TBs per dollar, but it's not the fastest drive in the world. Ironically, after your experiences, access speed may be my problem. It's always on, though, so iTunes should never had issues connecting to it.
     
  4. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #4
    I, too, run Western Digital Green Power 1 TB and 2 TB drives in my Drobo. One thing to keep in mind, though, is not to confuse the drive enclosure's power light with the internal drive's status. The WD drives - especially the Green Power (GP) - contain several power saving features, one of which is to spin down when not in use. There is a jumper setting or BIOS setting that can be changed (cannot remember which) to prohibit this, but my Drobo ignores all of that and spins down when not in use for heat and longevity reasons.

    Out of curiousity, how often is this happening? How is the NAS connected to the network? I know it would defeat the purpose of a NAS, but could you temporarily directly connect the NAS to the itunes host mac and see if the problem goes away? You aren't using the wake-on-demand feature, are you?
     
  5. rayward thread starter macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #5
    The NAS is connected the the USB port of network hub, which is an Airport Extreme. The iMac is connected via ethernet to the same AE. I'm not using wake-on-demand...as far as I know.

    I may have to do some research about settings for the NAS...
     
  6. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #6
    Here's one more question - although I haven't tried it nor do I want to do this experiment on my end?

    -What happens if you were to hypothetically reboot your computer, and your itunes library was on an external drive but disconnected? Would iTunes, upon loading, see the lack of a physical library and revert back to the default location?

    If this were the case, I wonder if perhaps iTunes is loading before your mac is able to mount the network drive? When is it defaulting back to the default location? Wouldn't be on a restart, would it?
     
  7. rayward thread starter macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #7
    I think this is exactly what's happening. I have iTunes set to open automatically upon booting, so it may be ahead of the game as far as the Mac recognising the network and picking up the NAS. I need iTunes open all the time, to feed my ATVs, but I'm going to take off the auto-open and see if manually opening it once the boot/connection process is complete avoids the issue.
     
  8. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #8
    You could get really fancy and construct something in automator have iTunes open only upon the mounting of the network drive...

    If this is indeed the issue, do us a favor and mark this thread as 'solved'.

    But do let us know. Holler!
     
  9. mavfan11 macrumors member

    Joined:
    May 6, 2008
    #9
    airport extreme itunes music library

    I put all my music on an external drive and attached it to my airport extreme after I got myself an intel SSD for my MBP last week as I didn't want 70GB of a 160GB SSD eaten up by music and podcasts.

    For the past week, every time I've rebooted iTunes it has been recreating the music folder in the default location and downloading new podcasts to it instead of to the external drive attached to the AE. This problem did occur before I installed the SSD but it happens every time now instead of just once in a while when I had a 7200rpm HD in the MBP.

    iTunes gets launched automatically much of the time as I'll have my phone attached and other times iTunes is the very first thing I open after it boots.

    I'm going to try attaching my phone a minuter or two after I start up and won't launch iTunes right off the bat either and see if that makes a difference.
     

Share This Page