Itunes library problem

Discussion in 'Mac Apps and Mac App Store' started by pretzel logic, May 14, 2008.

  1. pretzel logic macrumors newbie

    Joined:
    May 14, 2008
    #1
    Hi all, first time poster here with a problem.

    I had my itunes library stored on an 80 gb lacie external HD, and filled it, so got a 1TB WD Mybook. What I did was copy the music over and changed the location in itunes, which I now know is wrong. I then made an absolute mess of what i was doing by consolidating some of the library to the WD and then stopping and wiping the new WD hard drive. I then attempted to get everything back to the way it was on the lacie, but only the stuff not consolidated to the WD was consolidated to the lacie. Now most of my library has black circles with exclamations beside songs, and is asking to find the correct locations. The locations seem to be correct already, is there a quick fix to relocate all the songs? I have 3800 songs, and don't fancy doing this manually!! Also, clicking "Consolidate Library" has no effect on the library anymore...

    Desperately need help here guys. Thanks, Robert.
     
  2. rWally macrumors regular

    Joined:
    Sep 17, 2006
    Location:
    Denver, CO
    #2
    It's kind of hard to follow what you're saying here but I'd advise putting all your files on the hard drive you want, removing (DON'T ERASE) all the files from your itunes and then re-adding everything from the hard drive where the files are located.
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    It's very easy if you changed the new drive to the same name as your old drive and put the music folder in the exact same location. Test to see if it works, tHEN you should add songs.
     
  4. pretzel logic thread starter macrumors newbie

    Joined:
    May 14, 2008
    #4
    Thanks for the replies, I'm a little busy atm with uni exams, so haven't had a chance to do anything to my library.
    However, the first thing I wanted to do was get everything back to the original state on the Lacie HD. Atm, iTunes can't locate about 3000 songs, even though it appears their file directories are correct when I check them. It asks me to manually locate them, and has a black circle with an exclamation mark beside them. Is the any quick step to change these or find the files without doing each one individually?? It will take me an absolute lifetime doing this manually. Once I get everything back to the way I had it on my Lacie, then I will consolidate the library to my new WD, in the correct manner.
    Any ideas? Robert.
     

Share This Page