iTunes match 256 kbps not showing on iPhone 4.

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Hazzmatt, Nov 18, 2011.

  1. Hazzmatt macrumors newbie

    Joined:
    Nov 18, 2011
    #1
    I understand to upgrade songs in my library I need to delete from library, but not the cloud, and double click to re-download and then it does show as 256 kpbs. This of course being the songs on my computer's local drive. But..for my iphone 4, which does have iOS 5.0.1 the songs are still the original lower quality. I can't delete and re-download my iphone's songs via iTunes, but can on the phone itself. And even after I do this on the phone and resync it doesn't show a the 256kbps. It shows a "!" next to the song and I can't play it in iTunes, but I can on the iphone. Link to screenshot:

    http://i.imgur.com/9Lmj1.png
     
  2. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #2
    You have to enable iTunes Match on your phone too, which will delete any music currently stored on it and download playlists from the cloud. You can then specify entire playlists or individual songs to download using your phone.
    Settings>Music>iTunes Match
     
  3. Hazzmatt thread starter macrumors newbie

    Joined:
    Nov 18, 2011
  4. Patriot24 macrumors 68030

    Patriot24

    Joined:
    Dec 29, 2010
    Location:
    California
    #4
    When you say that you are "resyncing the phone", what do you mean by this? One of the advantages of Match is that you never need to plug your device into your computer to have the latest playlists, songs, etc. I'm just curious what you are doing in that regard?

    As for iTunes on your computer, you should enable the "iCloud Status" column and check to see if your songs were in fact matched or uploaded to the cloud. If they were not, this could be why when you delete the song off of the phone that you are now receiving an error (from my experience, the "!" icon typically means that the file cannot be found to play the song).


    Since the beginning of Match there has been this concept that the music on your iOS device would be completely wiped and replaced by Match data (perhaps because Apple themselves have said that at some point).

    However, when I turned on Match on my devices, it did not wipe any of the data. It simply kept the songs I already had on the devices and enabled Match so that I could download anything else I wanted.
     
  5. Hazzmatt thread starter macrumors newbie

    Joined:
    Nov 18, 2011
    #5
    Yeah, I just realized I don't have to actually sync anymore for the music to appear. I already did the "iCloud status" and see that most are matched but even half of those show as under 256kbps. This being under the top library , not what's on my iphone. I can't add do View Options to add any extra columns under my phone's music when it's connected.
     
  6. zhenya macrumors 603

    zhenya

    Joined:
    Jan 6, 2005
    #6
    Enabling Match will not wipe the music from your iOS device. If you have music synched on there that is of lower than 256kbps quality, it will stay there. If you want to replace it, you need to remove it from your playlist or whatever you use in iTunes that says 'sync this music to this device'. It will then be available on the device through iCloud, and once you play it, it will stay on the device as 256kbps quality.

    If you want to make sure all music is replaced, under the Music settings for that device in iTunes, make sure it is set to sync nothing. Then ALL your music will show up as cloud only, and as you play songs, they will be downloaded one by one at 256k.
     
  7. Hazzmatt thread starter macrumors newbie

    Joined:
    Nov 18, 2011
    #7
    I finally figured it out! With iTunes Match on in the iPhone and plugged into comp, the iTunes music tab just says iTunes Match is on and you can't choose all library or selected playlists to sync.
    So, I had to turn off iTunes Match in settings on iPhone. Plug in iPhone again, go back to Music tab and deselect Sync Entire Music Library>Apply and that took off all the music that was on there with less than 256kbps.

    Then go to music library and sort by Bitrate, delete all less than 256 and dub click to download higher quality version. Then make a smart playlist(since reg playlist won't go to the cloud) with all songs. The way I did that was by artist that was not "flkhascah" or whatever. Then go to that playlist on iphone, scroll to the bottom and Download All.

    Jesus Apple didn't make that easy!! Or have a KB article on it.
     
  8. Adrian232 macrumors newbie

    Joined:
    Jun 14, 2010
    #8
    Thanks! This worked for me also. In my situation I only synced a few mix playlists to my iPhone, so it was weird that all my playlists showed up but only the songs that were on the mixes were in them...
     

Share This Page