Itunes Match adds DRM

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by bcnmac, Feb 4, 2013.

  1. bcnmac macrumors member

    Oct 26, 2012
    Hi all,

    I'm using Itunes Match and have had mixed success with it. I'm also using Google Music as a backup service.

    Every so often songs I've downloaded from Itunes (songs that were matched, but ripped long ago from my cds) have DRM and can't be uploaded to Google Music.

    It's happened with a Zeppelin song, a Jayhawks song and an Ella Fitzgerald song. The rest of the songs from these albums were fine, DRM free, and uploaded to Google Music.

    I've deleted the DRM songs from icloud and tried to rematch them, but I get prompted to enter my username/pw to authorize the computer, everytime I play/access the song. I.e., I cannot play these songs locally, even though I have the files.

    Any ideas?

    Attached Files:

  2. Senseotech macrumors 6502a


    Nov 23, 2009
    These are tracks you purchased once upon a time when the tracks still had DRM, iTunes Match hasn't suddenly added DRM :rolleyes:
  3. bcnmac, Feb 4, 2013
    Last edited: Feb 4, 2013

    bcnmac thread starter macrumors member

    Oct 26, 2012
    This is not the case. These tracks were never purchased from itunes. These are CDs which I ripped (a long time ago) and matched (with itunes match). I then deleted the inferior local files a while back.

    Now I want to put my itunes music on google music also. I downloaded the matched itunes files (again, matched to ripped mp3 files). I was able to upload all the downloaded files, except for these 3 files which are DRM protected.

    I can't rematch the songs and I can't play them. For the rematch the icloud status is "waiting". For playback I get prompted to authorize the computer to play back the DRM protected songs. Yet putting in my id/pw has no effect. The metadata on the files shows my itunes account as the associated ID.

    Since these were matched and better quality than the originals (ripped when space was a premium) I can't go back to the original files to rematch them since I deleted them (may have a backup on some DVD somewhere, but don't want to resort to that).

    So I have 3 m4a files which are tied via DRM to my account, yet they can't be used.

    I'm really flummoxed by this.
  4. bcnmac thread starter macrumors member

    Oct 26, 2012
    Stranger still...

    I still can't play these songs in Itunes. But if I find the files in Finder, I can use Quick Look to play these songs.

    I've been trying to find out what is going on. I've added "Kind" to the columns in Itunes. Most matched songs download as "Matched AAC Audio File", but these 3 songs show up as "AAC audio File"
  5. AnonMac50 macrumors 65816

    Mar 24, 2010
    I don't use iTunes Match, but this does look weird. I think the best option is to contact Apple, or mail or in person.
  6. rednz macrumors newbie

    Feb 27, 2013
    I have also just started having this problem. I had an mp3 version of a song which has been matched by itunes. I then deleted the mp3 version of the song. However i can no longer play the new matched version and keep getting the same error as above.

    The track is DRM Free however it wont play in itunes, however it will play in finder.

    Really annoying, Why is itunes not letting me play my own music?
  7. jhenshaw macrumors newbie

    Jun 25, 2013
    Same problem here

    I have a set of 27 songs that were ripped from CD, then matched by iTunes Match. I deleted the original media to get upsampled copies from iTunes Match.

    I now find that they have DRM added, and it is NOT my Apple ID so I cannot play them at all.

    I have opened a support case with Apple. Any resolution to the other cases of this?
  8. Michael CM1 macrumors 603

    Feb 4, 2008
    I had a similar issue on the Man of Steel soundtrack. Only the last track, Arcade, gave me some "you need to authorize iTunes blah blah" message I hadn't seen in ages. This wasn't through iTunes Match or anything. This was after the first download. The song worked fine on my iPhone, iPad and Apple TV, but it was giving me trouble on my iMac.

    So I deleted the file and re-downloaded it. Problem solved. Well, mostly. That track still doesn't seem to EVER come up when I shuffle/repeat the album on my iPhone. I'm guessing it's some mystery glitch.

Share This Page