iTunes Match Artist/Album sorting issue on iPhone

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by BulkHedd, Nov 23, 2011.

  1. BulkHedd macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #1
    Ok, so yesterday I bought the new Michael Jackson "Immortal" CD (don't judge) because it was on sale & cheaper than iTunes.
    I imported it and it was instantly matched in the cloud.
    The problem is that on my iPhone it shows up as 8 different albums because of the various artists and collaborations. Also, if I go to Artist/Michael Jackson/Immortal it only lists some of the tracks, not all.
    So there is no easy way for me to just play the album straight through.
    I have tried setting the Sort options in iTunes on my MBP and it's listed correctly there, as well as in iTunes on my work PC, which uses my iTM account.
    But I can't get it show up properly on my iPhone.
    Any thoughts?
     
  2. Razeus macrumors 601

    Joined:
    Jul 11, 2008
    #2
    Why not just switch the Artist to Michael Jackson?

    Then you can sort your library by Album/Artist/By Year, to keep the album together, but the problem that non Michael Jackson artist go to the bottom of the album song list, thus throwing the song tracks out of order.

    This is what I do. If the song features another artist, I put it in the song title. It's a PITA and one of the reason I don't like messing with online music (because all the hip-hop artists have 20 billion artists on their albums making a sorting nightmare).
     
  3. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #3
    I could do that but they way I've fixed it in iTunes before was to tell it to sort by a specific artist.

    Now, if I change that in iTunes will Match keep the user-defined artist?

    Also, it's frustrating that I can't do this on the iPhone. Even though they are moving towards us using iOS devices without needing a computer, we still can't edit any track info on the iPhone.
     
  4. flatfoot99 Guest

    Joined:
    Aug 4, 2010
    #4
    did you try settings>music>group by album artist?

    you can also try changing album artist to various artist

    or try setting an album to a compilation album.

    I still don't know what the proper way is to deal with this...
     
  5. WisdomWolf macrumors regular

    Joined:
    Apr 15, 2010
    #5
    Sorting as broke again on iOS 5 with or without match. Hopefully 5.0.2 will address this and the iTM bugs.
     
  6. JPM42 macrumors 6502

    Joined:
    Oct 21, 2007
    #6
    In iTunes, try setting the album artist for all the tracks to Michael Jackson. Then on your iPhone, go to Settings/Music and switch on "Group By Album Artist".
     

Share This Page