iTunes Match - Item cannot be downloaded.

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by chrisworld, Jan 29, 2012.

  1. chrisworld, Jan 29, 2012
    Last edited: Jan 30, 2012

    chrisworld macrumors member

    Joined:
    Nov 14, 2006
    #1
    "This item cannot be downloaded"
    "The Item you have requested is not available for download."

    EDIT - See my updated post below to seek a remedy.
     
  2. Rampant.A.I. macrumors 6502a

    Joined:
    Sep 25, 2009
    #2
    Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    I don't know what's going on with the iTunes store lately, but it seems really glitchy. For weeks I was getting error messages every time I downloaded an app, saying that another app that never actually downloaded wasn't available. I tried relogging, checking my iTunes/apple ID, and nothing worked until it just decided to DL on its own sweet time.

    I've also noticed items I've been billed for and already downloaded don't show as purchased, and I can't write reviews... Meaning to call apple about that now the weekend's over.
     
  3. chrisworld thread starter macrumors member

    Joined:
    Nov 14, 2006
    #3
    I've been getting that buggy app thing too when downloading ANY app, the same error mentioning app x (where x is app name) cannot be downloaded but the current app downloads fine. It's been well over 2 weeks now.

    Wtf is apple doing?! I just dumped 300 for a 32 gig 4s, bought match, I'm a paying customer along with the others. Come on apple.
     
  4. chrisworld, Jan 30, 2012
    Last edited: Jan 30, 2012

    chrisworld thread starter macrumors member

    Joined:
    Nov 14, 2006
    #4
    ===========
    ***UPDATE***
    ===========

    After a TON of experimentation I figured out a (albeit a bit tedious and annoying) workaround.

    I deleted a TON of albums belonging to the same artist(s) (they were all compilation albums from the TV Show Samurai Champloo).

    Well, they're ALL apple lossless, but I was able to pinpoint the problematic one. "Departure" in full Apple Lossless would not re-download from the cloud as 256 kbps VBR aac. It just refused to re-download when uploaded in ALAC.

    The remedy? I made a COPY of the album in iTunes converted to AAC 256 and uploaded it first, and what do you know... I can download them. The reason I chose 256 AAC was because everything else iTunes related seems to be 256 - ALAC to iCloud and purchased tracks.

    However, I hope this can help people with the problem.

    As for now, I'm actually gonna try to convert them to WAV or AIFF then back to ALAC and try again. I wonder if the ALAC's had something wrong with them, a bit off on every single one from the same album, corruption. I have no idea.

    I'll post further results if I find that ALAC -> AIFF/WAV -> ALAC -> iTunes Match works in any way to remedy "broken" files.

    =============
    ***UPDATE 2***
    =============

    -Posting results of another experiment.

    ALAC -> AIFF/WAV -> ALAC -> iTunes Match (uploaded) -> Download.

    This method also fails, the end result file from match cannot be downloaded. I wanted to try it because I thought maybe a new copy of ALAC from a AIFF/WAV copy of the "broken" ALAC would fix bit errors/corrupt information/bad tags.

    This is very odd, but since the ALAC -> AAC -> Match (uploaded) works just fine, use that. If you must replace your ALAC in your local iTunes Library, put them back in last so when match sees them they will be considered duplicates and not try to upload/match.

    Hope this helps anyone with this exact same problem.



    Chrisworld

    Edit(s) - Fixed various typos and cleaned up the post. Was typing in a hurry. Fail.
     

Share This Page