ITunes Match - some songs won't play on iOS devices

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Sandman77, Sep 29, 2013.

  1. Sandman77 macrumors newbie

    Joined:
    Sep 29, 2013
    #1
    Hi all, I have been reading these forums now but only just registered as I can't find a solution to this problem I have.

    I just subscribed to iTunes Match yesterday and about 6000 songs were matched and about another 500 uploaded. This was all done on a Mac mini with the latest software. Anyway today I turned on match on my ipad and iPhone (and also my wife's iphone). My entire library shows up as expected on these devices but a lot of the songs won't play. If I select a track to play it will try to play it then skip to the next track. It will keep skipping tracks till it gets to one that it can play. The same tracks have issues on all my ios devices using match. The tracks I am testing are all "matched" tracks. Surely these should be the most reliable ones?

    I have tried disabling match and ensuring all music is deleted from the device then re-enabling it. This made no difference. I seem to be able to download these tracks but I should be able to just press play?

    Any ideas how to fix this?
     
  2. Sandman77 thread starter macrumors newbie

    Joined:
    Sep 29, 2013
    #2
    Just a quick update.

    I didn't do anything to solve this but everything is now working as expected. Looks like it just needed a bit if time to sort everything out on apples side (24 hours).
     
  3. bripab007 macrumors 6502

    Joined:
    Oct 12, 2009
    #3
    I've experienced this with at least two tracks I'm aware of so far on iTunes Match. I subscribed last week, and about 19k tracks out of my 25k were matched, the remainder uploaded.

    I'll have to try them again after a few days to see if anything's sorted.
     
  4. seecoolguy macrumors regular

    seecoolguy

    Joined:
    Nov 28, 2007
    #4
    I just noticed this with two tracks, I ripped these from my audio cd, they matched up on iTunes Match and are playable on the mac even if I delete the local file and play it just over the "cloud"

    running 10.9 with iTunes 11.1.3, however on my iPhone4S or 5S I cannot playback these two tracks? the rest of the album is matched as well and it plays just fine on my iOS device????

    It doesn't make any sense, the next step I'm going to try is to sync it up manually w/o iTunes Match and see if it plays, if it does then it's gotta be a problem with iTunes Match?
     

Share This Page