iTunes Media Function Keys Not Working

Discussion in 'Mac Basics and Help' started by KEITH1437, May 24, 2014.

  1. KEITH1437 macrumors newbie

    Joined:
    Mar 15, 2010
    #1
    So I picked up a new MacBook Pro Retina 13" yesterday, and it's going great so far, except for one thing. It seems that the Media function keys aren't working in iTunes?

    I checked under the keyboard preferences to ensure the "standard function" keys box wasn't checked, and it wasn't. All the other functions keys are working properly except the back, play/pause, and skip keys. I tested the keys with other functions, such as setting a shortcut to the F8 key, and it recognized the input, so its not a hardware issue.

    I tried to find help elsewhere, but most people seemingly just had that box in the settings checked, which wasn't the problem for me it seems.

    Any suggestions?
     
  2. kdorvil macrumors newbie

    Joined:
    Oct 24, 2013
    #2
    Did you ever find a solution? I'm having the exact same problem as you. My function keys are on the regular Launchpad, Mission control settings. Everything works except the Play/Pause, Rewind, and Skip buttons. It doesn't work on any app I use. I have a Refurbished 13 inch MacBook Pro with Retina, Late 2013.

    I hope you find a solution.
     
  3. railto macrumors newbie

    Joined:
    Dec 29, 2009
    Location:
    UAE
    #3
  4. krahunt macrumors newbie

    Joined:
    Oct 24, 2014
    #4
    The ultimate solution

    You have to do what railto says... Chrome>Settings>Extensions select media keys near to Google Play Music and select for all the fields "in Chrome" (not Global), you will have your media keys back, by the way, Apple support sucks!
     
  5. castillooo macrumors newbie

    Joined:
    Oct 14, 2015
    #5

    Just wanna say, Thank you guys. i've been looking for this for months.
     
  6. Chaxterium macrumors newbie

    Joined:
    Nov 5, 2015
    #6
    I had the exact same issue and this fixed it immediately. Disabled Google Play and voila, they worked.
     
  7. jdavis83 macrumors newbie

    jdavis83

    Joined:
    Mar 30, 2016
    #7
    I'm having a similar issue but I don't use google music. checked all extensions in chrome to see if they might be doing the same to no avail. Anyone run across this issue without the Chrome bug?
    --- Post Merged, Mar 30, 2016 ---
    Found it. It was the specifics to looking into google play that were throwing me off. If anyone stumbles on this as I did, Follow the above steps "Settings>Extensions" but scroll to the bottom and find the "Keyboard Shortcuts" button. Find any media services you have that may be hijacking your media keys and turn them off. Mine was Plex.

    Thanks for the help and starting point from all the other posters. Wouldn't have found this without y'all.
     
  8. sounds_good macrumors newbie

    Joined:
    May 5, 2016
    #8
    Any ideas for someone who doesn't use Chrome? I've never had Chrome installed on my MacBook Pro. I just noticed today that my play/pause & skip function keys are not working. I have no idea if it is related, but yesterday I did view a Google docs file which launched in Safari. There was no multimedia, simply a text document. I've rebooted the computer, iTunes is up to date and I'm running OS X 10.11.3.
     
  9. Tay428 macrumors newbie

    Joined:
    May 30, 2016
    #9
    --- Post Merged, May 30, 2016 ---
    I was having this same problem and didn't use chrome. What I figured out is if you have any other music app open like Spotify or tidal then those skip and play/pause functions won't work in iTunes so you have to quit those and then they will work. Hope this helps!
     
  10. sounds_good macrumors newbie

    Joined:
    May 5, 2016
    #10
    Unfortunately I don't use any other music app, only iTunes. I've shut down all programs as well as rebooted a number of times. Still not functioning.
     
  11. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #11
    Looks like Chrome decided to install the Music plug-in without asking, again.
     
  12. snowyjoey macrumors newbie

    Joined:
    Jan 15, 2012
    #12
    Will someone PLEASE answer sounds-good's post above. I am in the same position. I do have Chrome installed but never ever use it. I followed that process to check keyboard shortcuts and ALL are showing "Not Set" as I would expect as I don't use it. I use NO other music programs, only iTunes. my FF/Play/Rew buttons on keyboard stop working for no apparent reason (brand new keyboard just plugged in, direct from Apple), and the tracks randomly stop mid track. Extremely annoying. Does anyone have any clue what the issue could be please?
     
  13. Alireza1111 macrumors newbie

    Joined:
    Aug 11, 2016
    #13
    I have the same problem here! I recently installed Chrome on my Macbook pro, and media buttons, i.e play forward back, stop working after Chrome installation. There is not any extenson in my Google Chrome like "Google Play Music". Anyway I uninstalled Chrome and rebooted the system but the problem still exists!

    Please help me with this annoying problem. :-(
     
  14. Mason Dulemba macrumors member

    Mason Dulemba

    Joined:
    Mar 16, 2016
    Location:
    Richmond, IN
    #14
    Hate to Bring back this ancient thread, but the plex extension in chrome also by default hijacks the media keys, you can check if any chrome extension is hijacking media keys by going to chrome://extensions/ , scroll all the way to the bottom, click on keyboard shortcuts and look for something like "play/pause, next or previous" and click the X next to them to remove them from keyboard shortcuts, now your media keys should work like normal :)
    Hopefully this will save someone a lot of headache
     
  15. plea macrumors newbie

    plea

    Joined:
    Oct 16, 2017
    #15

    I had the same problem and it was not google chrome. I speak to apple customer service and after verifying 2 or 3 thing we shut down the computer and then press shift-ctrl-option-and the power button for 10 seconds, then wait 5 and turn on the computer. That was it, this restes the SMC on your Mac .. here the info
    https://support.apple.com/en-us/HT201295
     

Share This Page