iTunes message at startup

Discussion in 'Mac Apps and Mac App Store' started by flyman, Oct 20, 2012.

  1. flyman
    Expand Collapse
    macrumors member

    Joined:
    Jan 28, 2004
    #1
  2. ChristianVirtual
    Expand Collapse
    macrumors 601

    ChristianVirtual

    Joined:
    May 10, 2010
    Location:
    日本
    #2
    What OS version do you run ?

    Can you share from menu "about this Mac" ? Did you recently upgraded to newer OS X ?
    Newer version are mainly 64 bit. This can course trouble with older 32 bit components.
     
  3. flyman
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jan 28, 2004
    #3
    Yes and as it happens I've recently upgraded to ML.
    Heres a link to "about this Mac"...
    https://dl.dropbox.com/u/91487039/About%20this%20Mac.tiff
     
  4. ChristianVirtual, Oct 20, 2012
    Last edited: Oct 20, 2012

    ChristianVirtual
    Expand Collapse
    macrumors 601

    ChristianVirtual

    Joined:
    May 10, 2010
    Location:
    日本
    #4
    Try the following:

    1) Right-Click on iTunes icon
    2) Option-> Show in Finder
    3) Right-click on iTunes in Finder
    4) Get Info
    5) activate checkbox for "Open in 32 bit mode"

    Screen Shot 2012-10-20 at 9.04.28 PM.png

    I don't have any plug-in, so I'm fine with 64 bit; but give it a shot and let us know if it solve your issue.

    The difference between 32bit and 64bit is mainly about how software address the main memory (and also how much memory can be addressed). Mac OS X is now complete (more or less) to 64bit. 32bit is kind of legacy but still work on 64 bit machine; but sometimes with hickups as you experience here.

    You could try to get 64bit versions of your plugins too. That would be the better way.
     
  5. flyman
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jan 28, 2004
    #5
    Before I try this, is there away of telling which plug-in could be causing the issue and if I don't need could I just delete it?
     
  6. flyman
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jan 28, 2004
    #6
    I checked the box so it opens in 32 bit mode and the message has now gone.
    Is there away of finding out which plug-in was causing the message to appear?
     
  7. Xcallibur
    Expand Collapse
    macrumors 6502a

    Xcallibur

    Joined:
    Jul 24, 2011
    Location:
    Manchester
    #7
    Try opening finder and navigating to:

    Macintosh HD/Library/iTunes/iTunes Plug-ins

    You should see the plug-in named "CoverVersion" in there, just remove it. There may be a program associated with the "CoverVersion" plug-in though, if so, you're better off removing that program.
     
  8. flyman
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jan 28, 2004
    #8
    The only plug-in I had in that location was Quartz Composer Visualizer.bundle :confused:
     
  9. Cynicalone
    Expand Collapse
    macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #9
    It will be in the user library.

    From the Finder App.

    On the "Go" menu hold down the option key and you should see your "Library" appear. Click that and it will open your "Library".

    In that "Library" you should see an "iTunes" folder and inside that will be the "iTunes Plug-ins".
     
  10. Xcallibur
    Expand Collapse
    macrumors 6502a

    Xcallibur

    Joined:
    Jul 24, 2011
    Location:
    Manchester
    #10
    Ohh yeah sorry about that, I should have referred to the local plug-in folder. :rolleyes:
     
  11. flyman
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jan 28, 2004
    #11
    I took out the plug-in and so far so good!
    iTunes now running in 64 bit mode :)

    Thanks guys
     

Share This Page