iTunes Not Booting(?!)

Discussion in 'Mac Apps and Mac App Store' started by Mr. Monsieur, Oct 12, 2014.

  1. Mr. Monsieur macrumors 6502

    Joined:
    Apr 21, 2004
    #1
    Hello!

    I recently upgraded my 2009 MBP to an SSD, and ever since I have been unable to run iTunes properly (I pulled out the optical drive, put the SSD in, and then used Carbon Copy Cloner to clone my old HDD onto the SSD…I then deleted the application files from the HDD, and run applications off the SSD, which is the boot drive, and keep most of my files on the HDD).

    Now when I run iTunes, this message appears: “You do not have enough access privileges for this operation.” On the left side of the dialog box is a red octagon with a white exclamation point in the middle of it.

    When I click on “OK,” I then get another dialogue box with this message: “An unknown error occurred (-45054).

    After this iTunes closes.

    My thought was to uninstall and then reinstall iTunes, but I can’t find iTunes in the App Store(!)

    I searched the MacRumors forums for a solution, and tried holding down the option key as iTunes boots up, I then tried choosing both the new iTunes library file (on the SSD), as well as the old iTunes library file (on the old HDD), in both instances I got the above error messages…

    Any thoughts would be much appreciated!
     
  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
  3. MacTCE macrumors 6502

    Joined:
    Dec 20, 2013
    #3
    I would go to Disk Utility and use the "Check Permissions" and "Repair Permissions" on both drives. That may solve your issue.
     

Share This Page