iTunes not connect to ipod touch

Discussion in 'iPod touch' started by remyfaf, Dec 3, 2008.

  1. remyfaf macrumors newbie

    Joined:
    Jun 20, 2008
    #1
    Hi,
    Yesterday I had a new ipod touch 32GB 2g. Tried to connect rignt away to my MacBook Pro to sync everything and I get:
    iTunes could not connect to the iPod "iPod" because an unknown error occurred (0xE8000001)

    I´ve tried everything I have found in the web:

    1. Reinstalled iTunes 8.0.2 (having properly deleted the previous one), restarted the computer and the ipod. Same problem.

    2. Restored the ipod. Same problem.

    3. Restart eveything. Same problem.

    4. Interestingly, it did work on a PowerMac G5 with iTunes 8.0.1.. The ipod touch got started perfectly. The ipod seems to be working well. So I installed iTunes 8.0.1 on my MacBook Pro. Same prioblem.

    5. I connected my old 5gen ipod and synced perfectly just like it used to do.

    Can anyone help me?

    Cheers
     
  2. remyfaf thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #2
    one important addition

    I logged as another user in the same computer, using same iTunes and it worked fine. There is something in my user account. Is it that I used to sync iTunes to my old 5th gen ipod? Is it some conflicting software that I have?
    I´ll post any finding.
     
  3. remyfaf thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #3
    Solution

    Gathering pieces of information from http://www.fixya.com/support/t777187-iphone_3g_error_0xe8000001, what I did is the following:

    1. Under another user account of the same computer (MacBook Pro), I connected the iPod Touch. It was perfectly recognized by iTunes.
    I saw that a file was created in ~/Library/Lockdown just by connecting the ipod.

    2. I came back to my account and saw that I did not have the directory ~/Library/Lockdown. I simply copied the directory (wit the file it contained) from the other account to mine, and iTunes recognized and synced perfectly.

    To make that copy you need administrator privileges to override directories protection.

    Hope this will be useful to someone.

    Cheers
     

Share This Page