iTunes not displaying Store correctly. showing content in one big column

Discussion in 'OS X El Capitan (10.11)' started by agdickinson, Oct 11, 2015.

  1. agdickinson macrumors member

    Joined:
    Jun 17, 2003
    Location:
    Marston Green, West Midlands, UK
    #1
    Hi,

    I have El Capitan and iTunes 12.3, and it is not showing the iTunes store correctly, with some rather strange formatting, and not showing columns just rows. Seems to be some sort of the HTML type formatting issue.

    So in iTunes Store 'Movies' I see 'New and Noteworthy', then See All and then one single column of films.

    ie

    Paper Towns
    Jurassic World

    etc

    in one single column

    Any help would be appreciated.

    Andrew
     
  2. CaTOAGU macrumors 6502

    Joined:
    Jul 15, 2008
    Location:
    Manchester, UK
    #2
    This started happening to me a couple of days ago. I fixed it by clearing the iTunes cache in my home directory's library.

    1./ Close iTunes
    2./ In Finder hold down alt, then on the menu bar click Go -> Library
    3./ Open the folder Caches
    4./ Delete the folder com.apple.iTunes

    Hope this helps.
     
  3. agdickinson thread starter macrumors member

    Joined:
    Jun 17, 2003
    Location:
    Marston Green, West Midlands, UK
    #3
    Hi,

    Thanks that fixed it.
     
  4. CaTOAGU macrumors 6502

    Joined:
    Jul 15, 2008
    Location:
    Manchester, UK
    #4
    You're welcome, glad I could help.
     
  5. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #5
    I got all excited for a second... but nope, looked correct for half a second then went back to the long column "view". Someone on Apple forums has a theory – not sure if correct – that the Store mistakenly pulls the mobile CSS file rather than desktop one, then applies it to desktop content.
     
  6. CaTOAGU macrumors 6502

    Joined:
    Jul 15, 2008
    Location:
    Manchester, UK
    #6
    That's interesting, it's worked on two of my machines, plus someone else's that had the same problem in a different thread. Did you make sure to close down iTunes first?
    The only other thing I'd done previously was to reset the store cache, iTunes -> Preferences -> Advanced, click on 'Reset Cache'. But on it's own, that hadn't fixed it for me. It wasn't until I deleted the cache from the home directory that it worked.

    The mobile CSS theory sounds possible, what was downloading initially didn't look like the desktop store to me. Have you changed the User Agent String in Safari to an iOS option in any windows or tabs? If this question doesn't make sense to you can probably ignore it as a possible solution.
     
  7. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #7
    Ha! Works now. I needed to do both: reset cache in iTunes -> Preferences -> Advanced AND delete the folder. Now everything looks good. Thank you!

    I hope they manage to fix it on their end somehow though, imagine telling millions of users "well you just have to go to your Library folder... no, Granny Weatherwax, not the one with books, the one on your hard drive... what is a hard drive? well..." ;)
     
  8. GeertGB macrumors newbie

    Joined:
    Dec 26, 2007
  9. CaTOAGU macrumors 6502

    Joined:
    Jul 15, 2008
    Location:
    Manchester, UK
    #9
    Yay, glad it's working now.
     

Share This Page