iTunes=not enough memory?

notredewey

macrumors member
Original poster
Jul 16, 2006
57
0
When trying to start iTunes a message comes up and tells me I do not have enough memory available. I have 19.5 GB left on this partition, and according to istat i have 404 mb free. I tried quiting all apps before launching itunes and still no luck. Any suggestions? Thanks.
 

solvs

macrumors 603
Jun 25, 2002
5,693
1
LaLaLand, CA
This happened on my Mom's Mac mini. Just delete the Pref files and iTunes itself, redownload it from Apple's site, and reinstall from scratch. Fixed hers. Might want to restart too.
 

notredewey

macrumors member
Original poster
Jul 16, 2006
57
0
Yea I was gonna try to reinstall. Its just weird how it started from no where. As for system maintenance I did run disk utility today.
 

nakedguy

macrumors member
Sep 30, 2006
43
0
This is a known issue on people running Hackintosh on their "normal" PC's. Other than that it works like a charm in my MB.
 

notredewey

macrumors member
Original poster
Jul 16, 2006
57
0
Thanks everyone. The reinstall did the job. I have another questions too but not sure if I should start a new thread. Maybe those of you who responded to this question could help. Some of my iLife apps are not working correctly. iMovie loads up my video and just quits. No pop up or nothing just dies. This is the same with Garageband. iWeb is the other app that I am having problems with. It starts up unlike the other two but won't let me do anything with it. Can't start new page, edit, etc. It just gives me "site" in the left column. I tried the archive and install a few days ago and no luck with that. All the other iLife apps are working fine, like iCal, and iPhoto. Any suggestions on this problem? Thanks.
 

nakedguy

macrumors member
Sep 30, 2006
43
0
I don't know of a magical solution to your problem but if your system is that scrambled maybe a system re-install wouldn't be a bad option.
 

MysticHalo

macrumors newbie
May 27, 2009
1
0
Houston, TX
Didn't work

Okay, deleting pref files and reinstalling did NOT work for me. What do I do now?

Computer: Apple PowerBook G4 12" Original 256 MB memory
*Added 1 GB memory 3 weeks ago and has been working fine
Bought computer in August 2004, new hard drive installed March 2007

I have NEVER had a problem with iTunes before. I have my library installed on my external hard drive. Why would it just suddenly fail to open? When I first got the message, I shut down my computer and let it sit for about 10 minutes before restarting it and that didn't work. Then I read on here to delete the pref files and reinstall which I did, including deleting the trash before reinstalling. Do I need to delete everything restart, and THEN reinstall? Please help...