iTunes not launching

Discussion in 'Mac Apps and Mac App Store' started by colder, Aug 19, 2010.

  1. colder macrumors member

    Joined:
    Aug 10, 2010
    #1
    Does anyone else have this issue?

    I am using the latest version of iTunes on Windows Vista, but this issue has been around for a while in my experience.

    I double-click on the iTunes icon on my desktop. I get the hourglass for a second, but then nothing happens. I can do this as many times as I like and the program will not launch.

    Checking Task Manager, I see the iTunes process is running as is the iTunes helper. I kill both, then try to launch iTunes - same thing. Nothing.

    The only way I can for sure get iTunes to launch is to connect my iPhone. That causes the program to start and the sync process to begin.

    What is the deal? Anyone else have this problem?
     
  2. Bkxmnr macrumors regular

    Bkxmnr

    Joined:
    Feb 9, 2009
    Location:
    Wichita, KS
    #2
    This happens to me when I have another user running and iTunes is running under that user (usually my kids). Other than that, have you tried rebooting?
     
  3. colder thread starter macrumors member

    Joined:
    Aug 10, 2010
    #3
    I don't think that's it, as no one uses this computer but me.

    I can reboot and that does resolve the issue, it's just irritating to have to reboot every time I want to start iTunes.

    This is a fresh build too, I just formatted the drive and reinstalled Windows about a month ago.
     

Share This Page