iTunes not letting me import music

Discussion in 'Mac Apps and Mac App Store' started by saucy1360, Sep 1, 2010.

  1. saucy1360 macrumors regular

    Joined:
    Jun 15, 2010
    #1
    Just within the last day or two, iTunes has stopped letting me import more music. When I File -> Add to Library, the song doesn't add (I'm using MP3, not some weird file that iTunes doesn't allow). And also when I drag and drop it doesn't work.

    I don't know why it's suddenly doing this, I've been adding my music that way for years. Can anyone help me out?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    The files might be corrupt. Try converting them from mp3 to mp3, creating new files, and then import those. You can use apps such as Max, Audacity, All2MP3, etc. for the conversion.
     
  3. saucy1360 thread starter macrumors regular

    Joined:
    Jun 15, 2010
    #3
    I don't think the files are corrupt because it's happening with EVERYTHING I try to add in.
     
  4. saucy1360 thread starter macrumors regular

    Joined:
    Jun 15, 2010
    #4
    Still not sure what the problem is. I even upgraded to iTunes 10 and it still doesn't work. The only way I've gotten something to be added to my library is if I had just recently downloaded it and double clicked it in that little Downloads window that comes up. Anyone?
     
  5. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #5
    Are you on a windows box or Mac?

    I know if you are on windows and the files are open with another program you can't bring them into another program. I would close all programs and then fire up iTunes again.

    Also are the files located on a network drive?

    Just a wild guess because I had it happen to me before.
     
  6. saucy1360 thread starter macrumors regular

    Joined:
    Jun 15, 2010
    #6
    I'm on an iMac. Everything is on the stock hard drive..
     
  7. ahollywoodcraig macrumors member

    Joined:
    Jan 2, 2007
    #8
    I'm having this same issue with iTunes 10.0.1 I have tried every method of importing the mp3s with no luck. I have repaired permissions twice, and I finally tried reinstalling itunes but still have the problem. I tried the app recommended and it repaired the files, but they still won't import. Any other suggestions? This just started happening a week ago which is the weird part. At one point with the same version of itunes I had no problems.
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    Did you try my suggestion in post #2?
     
  9. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #10
    Take a look at this thread:
    MacRumors: Forums > Apple Systems and Services > Mac Basics and Help > cant add music to my itunes HELP!
     
  10. ahollywoodcraig macrumors member

    Joined:
    Jan 2, 2007
    #11
    Well after all of my troubles I decided to try the one thing I had not done and that was to just use different mp3s and try to import those. It worked. I feel dumb. Thanks for all of your help though!
     
  11. Gdubyew macrumors newbie

    Joined:
    Jan 4, 2015
    #12
    I know this is several years late but I just experienced this on my iMac (running iTunes ver 12.5.1.21 and OS 10.11.6).

    I created a sound file in Sound Studio (version 4.8.2) and the aac file wouldn't import into iTunes. I tried with an m4a version of the file. No change. I tried a totally unrelated file and it imported fine. Hmmm.

    My temporary fix was to import the Sound Studio file into Quicktime and then had Quicktime export the audio only (even though it's only audio, anyway). The exported file imported just fine into iTunes.

    So there you have it. I might need to update my Sound Studio or fix/rebuild prefs and/or permissions.


     

Share This Page