iTunes not recognising my iDevices

Discussion in 'Mac Apps and Mac App Store' started by iTouch.lover22, Mar 9, 2011.

  1. iTouch.lover22 macrumors regular

    Joined:
    Oct 30, 2009
    #1
    Hey everyone, I've got a problem with my iTunes on my MacBook, thought this was the best place to put the thread. So I have a late '08 MacBook C2D, and recently upgraded to Snow Leopard (currently 10.6.6). Since then, both my iPad and iPod touch 4th gen have failed to be detected by iTunes. iPhoto pops up when I plug them in, but nothing on iTunes. What I've noticed is that every time I install an update for iTunes, it will work fine until I restart the computer, then all connections are lost again. I've read online that reinstalling iTunes each time would be a temporary solution, but other than that, I don't know if there's a better way to deal with it. It seems to be a common problem, anyone else experience it? I would've thought one of the 'bug fixes' would've fixed the issue. And I apologise if this has been asked before, but I haven't found a thread about it. Thanks!
     
  2. Jolly Giant macrumors 6502a

    Jolly Giant

    Joined:
    Sep 15, 2010
    Location:
    Hamburg, Germany
  3. iTouch.lover22 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #3
    Thanks mate, that second article was completely unrelated but the first one led me to another link which has the problem addressed (here). I never came across the article for some reason, but I'm going to install the update now and restart to see if it's fixed. Thanks!
     
  4. Jolly Giant macrumors 6502a

    Jolly Giant

    Joined:
    Sep 15, 2010
    Location:
    Hamburg, Germany
    #4
    hmm, i thought you said earlier

    iPhoto pops up when I plug them in

    keeping my fingers crossed
     
  5. iTouch.lover22 thread starter macrumors regular

    Joined:
    Oct 30, 2009
    #5
    Aaaaand it worked!!! Thanks for the help! Time to sync some movies to my iPad :D
     

Share This Page