iTunes not storing files in Library

Discussion in 'Mac Apps and Mac App Store' started by dschultz, Oct 16, 2010.

  1. dschultz macrumors newbie

    Joined:
    Oct 24, 2008
    #1
    I have my iTunes library set to an external drive. The boxes in Pref/advanced are check. I have checked my internal drive in the old iTunes location and see new podcasts and music living there. I need to perform a organize library to move the files.

    This seems to have happened in iTunes 9 and 10.

    Any ideas? The iTunes Music library does point to an external.
     
  2. Jolly Giant macrumors 6502a

    Jolly Giant

    Joined:
    Sep 15, 2010
    Location:
    Hamburg, Germany
    #2
    with iTunes media folder location (preferences > advanced) pointing to the desired location, consolidate your library:

    iTunes > file > library > organize library > consolidate files. if the option to upgrade to iTunes media organization is available, you might want to select that too.

    this will copy all files iTunes is aware of to the location set above (unless the files are already in that location).
     
  3. dschultz thread starter macrumors newbie

    Joined:
    Oct 24, 2008
    #3
    I have iTunes set up to place files in the Library location.

    Example:

    Library location in pref/advanced is: /Volumes/external/Music/iTunes
    both boxes are checked.

    but every so often (not every download) my podcasts are in:

    user/iTunes/iTunes Music/Podcasts

    it happened to one podcast last night; all others downloaded to the correct location.

    I case easily fix with the consolidate but would rather not have to watch what iTunes is doing all the time.

    Dave
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    That may happen if you launch iTunes without the external drive mounted. Make sure the external drive is available before you launch iTunes.
     
  5. dschultz thread starter macrumors newbie

    Joined:
    Oct 24, 2008
    #5
    Thanks!

    I launch iTunes automatically when I login.

    My external drives spin down when idle; they show up a mounted in the OS but they take 10-20 seconds to spin up if idle. Do you think this is the issue?

    Is there a workaround in the OS?

    The drives are LaCie D2 Quadras (Two units configure in the OS as a mirror.

    I never shut the external drives off so setting them to "ON" instead of "AUTO" is not desirable.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    As long as they're mounted, iTunes should see them, even if it has to wait for them to spin up again.
     
  7. dschultz thread starter macrumors newbie

    Joined:
    Oct 24, 2008
    #7
    The external is always mounted.

    Would there be any system logs that I could look at to troubleshoot?

    I am going to leave the drives on for a few days and see what happens.
     
  8. Jolly Giant macrumors 6502a

    Jolly Giant

    Joined:
    Sep 15, 2010
    Location:
    Hamburg, Germany
    #8
    see this: Checking Console for clues
     

Share This Page