iTunes plays 8 seconds then skips to next track

Discussion in 'Mac Apps and Mac App Store' started by knotgreen, May 27, 2013.

  1. knotgreen, May 27, 2013
    Last edited: May 27, 2013

    knotgreen macrumors newbie

    Joined:
    Mar 4, 2010
    #1
    Hey all,

    As the title says, iTunes will play ~8 seconds of a track and then skip to the next. This is an issue only with albums I've added in the last month or so. My iTunes is up to date, and I checked Get Info > Options and the start/end time is fine. I've also played the tracks elsewhere, and they don't skip, so it seems the files are not damaged.

    I'm at a bit of a loss here... I'd hate to reinstall and have to rebuild my library as it takes like 18 hours.

    Any advice is really appreciated.
     
  2. jdblas69 macrumors regular

    Joined:
    Aug 15, 2012
    #2
    Are these recent albums you added purchased from the itunes store?

    If so could you delete and re-download them? I heard someone else have this problem and if I recall after they re-downloaded them all worked fine.
     
  3. knotgreen thread starter macrumors newbie

    Joined:
    Mar 4, 2010
    #3
    No, they are live albums I've downloaded from archive.org and also some of the Daytrotter sessions, downloaded from their site. It seems to matter little where the files come from, as it's happening to all of them.

    Thanks for the reply.
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  5. knotgreen thread starter macrumors newbie

    Joined:
    Mar 4, 2010
    #5
    Why is this necessary? What about a WAV or MP3 file would make iTunes skip the track after 8 seconds?
     
  6. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #6
    Worth a try IMHO. The conversion may fix any encoding errors, who knows how well they were encoded unless you encode them yourself.
     

Share This Page