iTunes plays (internally) different move than Apple TV

Discussion in 'Apple TV and Home Theater' started by SpecFoto, Jun 9, 2016.

  1. SpecFoto, Jun 9, 2016
    Last edited: Jun 9, 2016

    SpecFoto macrumors member

    Joined:
    Oct 23, 2013
    Location:
    So Cal
    #1
    Recently set up a 2nd Mac Mini, 2009 Core 2 Duo, to work with Apple TV3 and home share. All is good except for some reason once I select a movie via Home Share and it starts on the Apple TV, sometime thereafter iTunes on the MM starts playing another movie, TV show or music while continuing the Apple TV selection. I know this because I can hear the sound playing through the internal Mac Mini speaker. If I turn the volume on iTunes off, then it becomes a problem for the Apple TV with volume adjustment.

    This does not happen with my 2012 MM used here before, (but now at another location) it did not play something else while Apple TV is using it's iTunes library. I have searched all menu items and preferences on both minis and they seem to be the same. Any suggestions on how to keep iTunes from playing a second selection? Both minis are on Mavericks and iTunes 11.4
     
  2. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
  3. SpecFoto thread starter macrumors member

    Joined:
    Oct 23, 2013
    Location:
    So Cal
    #3
    Never used Airplay, all is wired via ethernet.
     
  4. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
    #4
    Oh... maybe try it and see if it works that way.
     
  5. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #5
    Your Mac Mini is picking up signals from your Apple TV Remote, probably. On the Mini:
    1. Launch System Preferences.
    2. Click on the “Security” control panel.
    3. Click on the lock icon in the lower left corner and enter your Admin password.
    4. Select the checkbox next to “Disable remote control infrared receiver”
    5. Close System Preferences.
     
  6. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #6
    IMHO even over the wire iTunes streaming to aTV is called AirPlay. It's the name of Apple proprietary protocol.
    I have the same 2009 Mac Mini set up as my iTunes server, both it and aTV are wired to same ethernet hub. I have never noticed the problem you mention. To be honest, I use my MM headless, so I only navigate it via aTV, iPhone or iTunes on my MacBook. The only time I have heard iTunes on Mini to start playback is when I used Remote app on iPhone and opened the iTunes library there and started playback. That kicks it off on the target iTunes, not the AirPlay to aTV.

    My Mini is on latest on everything. El Cap and iTunes 12.4

    EDIT: Darth.Titan may be spot on, esp if iTunes is the foreground app on your Mini. But, shouldn't pairing aTV remote with just your aTV (see aTV manual) achieve just the same effect?
     
  7. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #7
    no, pairing only affects the receiver.
    an unpaired receiver will listen to all remotes, you would have to pair the mini to a different remote.

    more in depth...
    apple remotes have a code 0-255, they send that with the command, for example "Play 85."
    Paired receivers only listen to remotes with the same number.
    Unpaired receivers listen to all numbers.

    even more in depth...
    http://www.tinbert.com/iRedLite/downloads/iRL-AppleRemoteIDs.pdf
     
  8. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #8
    Thanks! Again something learned.
     
  9. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #9
    I have 2 Apple TV3's on ethernet and a 2012 Mini for a server running Mavericks and iTunes 11.2. Never saw anything like this happen.
     
  10. SpecFoto thread starter macrumors member

    Joined:
    Oct 23, 2013
    Location:
    So Cal
    #10
    Thank you, this was the problem. Note for others, the checkbox in step 4 is only available if you click on the Advanced tab in the lower right. (Mavericks 10.95)
     

Share This Page