itunes Problem since Lion upgrade: Major Lag

mtk642

macrumors newbie
Original poster
Jul 21, 2011
1
0
Ever since I upgraded to lion I have occasionally been getting lag and the rainbow pinwheel pops up, which happened 6 times when typing this post and all I am doing is running Safari.

This is really happening a lot though when I am playing songs from my iTunes library. It will work fine at first but then will lag and even freeze my computer for anywhere between 5 to 30 seconds. I have had to use pandora to listen to music ever since I upgraded.

I am overall impressed with the new features of lion, but this lag and the pinwheel popping up all the time, even when I'm not running iTunes is really starting to get my frustrated :mad:
 

kwiqsilver

macrumors newbie
Oct 23, 2009
7
0
Same here.
When I switch between TV Shows and iTunes DJ (or any other category), it takes several seconds to a minute to switch.
I also get horrible skipping. I've switched to VLC for now.
 

SvK

macrumors 6502
Jan 12, 2005
285
0
San Diego
Same thing here,

the "playback" lag is also manifested outside of iTunes when previewing audio / movie files (hit the spacebar on a file name...that's preview)

i though it was my SSD,

best,
SvK
 

darster

Suspended
Aug 25, 2011
1,703
1
I have not come across lag issues while listening to my music in itunes. It also streams with no problems with my other devices. However, one issue for me with lion and itunes occurs when I want to preview a song in itunes store. I have to click the play button twice in order for the clip to play. I did reset my PRAM after install of Lion, so maybe that has helped.
 

shwishbee

macrumors newbie
Oct 26, 2011
2
0
itunes and lion problem.

Help!!!
I have a macbook pro and I recently upgraded to lion. Ever since I upgraded my music in iTunes has not been the same. Some of my songs only partially play. There does not seem to be any pattern to this problem. The songs that play partially are random. They are off different albums some of which were purchased off iTunes, others were downloaded off albums I own. I have tried going to get info then checking start and finish times but they look fine. I cannot seem to solve it. Any answers out there??? it is extremely frustrating. This only started when I upgraded to lion. Please help!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.