itunes Problem since Lion upgrade: Major Lag

Discussion in 'Mac OS X Lion (10.7)' started by mtk642, Jul 21, 2011.

  1. mtk642 macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    Ever since I upgraded to lion I have occasionally been getting lag and the rainbow pinwheel pops up, which happened 6 times when typing this post and all I am doing is running Safari.

    This is really happening a lot though when I am playing songs from my iTunes library. It will work fine at first but then will lag and even freeze my computer for anywhere between 5 to 30 seconds. I have had to use pandora to listen to music ever since I upgraded.

    I am overall impressed with the new features of lion, but this lag and the pinwheel popping up all the time, even when I'm not running iTunes is really starting to get my frustrated :mad:
     
  2. kwiqsilver macrumors newbie

    Joined:
    Oct 23, 2009
    #2
    Same here.
    When I switch between TV Shows and iTunes DJ (or any other category), it takes several seconds to a minute to switch.
    I also get horrible skipping. I've switched to VLC for now.
     
  3. SvK macrumors 6502

    SvK

    Joined:
    Jan 12, 2005
    Location:
    San Diego
    #3
    Same thing here,

    the "playback" lag is also manifested outside of iTunes when previewing audio / movie files (hit the spacebar on a file name...that's preview)

    i though it was my SSD,

    best,
    SvK
     
  4. darster Suspended

    Joined:
    Aug 25, 2011
    #4
    I have not come across lag issues while listening to my music in itunes. It also streams with no problems with my other devices. However, one issue for me with lion and itunes occurs when I want to preview a song in itunes store. I have to click the play button twice in order for the clip to play. I did reset my PRAM after install of Lion, so maybe that has helped.
     
  5. shwishbee macrumors newbie

    Joined:
    Oct 26, 2011
    #5
    itunes and lion problem.

    Help!!!
    I have a macbook pro and I recently upgraded to lion. Ever since I upgraded my music in iTunes has not been the same. Some of my songs only partially play. There does not seem to be any pattern to this problem. The songs that play partially are random. They are off different albums some of which were purchased off iTunes, others were downloaded off albums I own. I have tried going to get info then checking start and finish times but they look fine. I cannot seem to solve it. Any answers out there??? it is extremely frustrating. This only started when I upgraded to lion. Please help!
     
  6. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #6
    Its the "Upgrade" process.

    Clean install lion.
     
  7. alienvoord macrumors newbie

    Joined:
    Sep 9, 2009
    #7
    I am also having iTunes skip whenever I open a webpage or an application.

    How? I bought Lion from the App Store. I have no Lion install disk.
     

Share This Page