iTunes problem

Discussion in 'Mac Apps and Mac App Store' started by Oktober, Oct 11, 2011.

  1. Oktober macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
    #1
    For a while now, so not since 10.5 I get the message below. How do I stop getting the message?

    Thanks

    Darren
     

    Attached Files:

  2. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #2
    What setting do you have for iTunes in your Firewall settings?

    System Preferences > Security & Privacy > Firewall.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    System Preferences > Security & Privacy > Firewall > Set access for specific services and applications
    Add iTunes to the list, allowing incoming connections.
     
  4. Oktober thread starter macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
    #4
    Yes I have it set to allow incoming connections.
     

    Attached Files:

  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    If that's the case, you shouldn't be seeing the message. However, I've seen it from time to time with apps that are on that list, just not frequently.
     
  6. Oktober thread starter macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    Not that I'm aware of. I know it's a nuisance. Maybe someone has a fix for it, but I haven't seen one.
     
  8. devburke Guest

    Joined:
    Oct 16, 2008
    #8
    Used to happen to me every time. I think it was from library sharing. I deleted iTunes and downloaded it again from the website, and it stopped. Can't promise it'll work for you.
     
  9. Jolly Jimmy macrumors 65816

    Jolly Jimmy

    Joined:
    Dec 13, 2007
    #9
    This can happen with code signed apps that have been modified somehow. This invalidates the certificate and makes OS X prompt for firewall permission every time. Removing the app in question and re-installing it should fix it if this were the case.
     
  10. cerote macrumors 6502a

    cerote

    Joined:
    Mar 2, 2009
    #10
    I have always had this when I turn on home sharing.

    Turn off home sharing and it stopped. Tried reinstall several times and never works. Learned to cope with it I guess myself.

    And now wifi-sync I just leave itunes open anyway now.
     
  11. Oktober thread starter macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
    #11
    You might have something there with regards to home sharing.
     

Share This Page