iTunes Radio slow and unresponsive

Discussion in 'iOS 7' started by Tbdbuckeyeitl, Sep 18, 2013.

  1. Tbdbuckeyeitl macrumors regular

    Joined:
    Jul 25, 2012
    #1
    My update went good but iTunes Radio is slow to start if at all and very I responsive. Am I the only one ??? I did a reset and a reset all settings.
     
  2. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #2
    For a little while on my iPhone 4S iTunes Radio says Network Unavailable. But now it just started working.
     
  3. kas23 macrumors 603

    kas23

    Joined:
    Oct 28, 2007
    #3
    Yes, you need to have a good internet connection for it to work.
     
  4. Tbdbuckeyeitl thread starter macrumors regular

    Joined:
    Jul 25, 2012
    #4
    On mine it's hit and miss if I can get a station to play. If it does play it takes a minute or so. Is this normal
     
  5. ren857 macrumors member

    Joined:
    Oct 23, 2007
    #5
    Give it a week or so for the newness to wear off. Everybody is trying to use iTunes Radio at the same so it's going to be slow at first.
     
  6. Tbdbuckeyeitl thread starter macrumors regular

    Joined:
    Jul 25, 2012
  7. Dokk macrumors regular

    Joined:
    Jun 20, 2010
    Location:
    IA, TX ... I never know
    #7
    I had no problems on wifi today, but 4G was nearly useless. Like others, however, I'd guess that today is hardly a good indicator of "normal."
     
  8. ren857 macrumors member

    Joined:
    Oct 23, 2007
    #8
    It was when starting up and I was on wifi. I haven't tried it on cellular data yet, but I will tomorrow.
     
  9. Dokk macrumors regular

    Joined:
    Jun 20, 2010
    Location:
    IA, TX ... I never know
    #9
    I take it back ... it's slow on wifi for me right now, too. Again, I'm betting it's just the newness of it for the many folks who installed iOS 7 today.
     
  10. jplusc macrumors 6502a

    Joined:
    Jul 5, 2010
    #10
    It's never been as slow as it's been today for me. During the beta phase it worked great. I'm guessing its apples servers being slammed today.
     
  11. ValerieDurden macrumors 6502a

    Joined:
    Feb 3, 2010
    Location:
    Philadelphia, PA, USA

Share This Page