iTunes Really Slow....

Discussion in 'Mac Apps and Mac App Store' started by mitchellr1705, Feb 15, 2009.

  1. mitchellr1705 macrumors newbie

    Joined:
    Jul 7, 2008
    #1
    For the past 2/3 weeks the itunes store has become extremely slow and to load a page on it takes 2-3 minutes!!!

    It also has loads of missing images/links and when buffering a preview track it takes up to 30 seconds to play a few seconds of the track.

    It is defiantly not a problem my end with internet and it is over 2MB.

    I have just read on the Apple Discussions that this is happening to other people with the latest updaye

    http://discussions.apple.com/thread.jspa?messageID=6498968

    Is anyone else having this problem - and can I downgrade to a lower firmware while Apple patch this.

    I'm guessing they are losing $millions from this

    Thanks

    Mitchell
     
  2. cawesjmu macrumors 6502

    Joined:
    Apr 4, 2004
    Location:
    Richmond, VA
    #2
    load full preview?

    I don't have an answer for you, but I had a similar question, so I hope we can both get some answers. I could swear I remember seeing a "load full preview" when playing previews of songs. So that it doesn't cut off and "rebuffer" half way through the preview. Any body remember that, or am I crazy? It is no longer an option? I saw in the advanced section, how to select the streaming buffer size, but it does not have a "full" option, just small, medium or large.
     
  3. thedward28 macrumors newbie

    Joined:
    Mar 8, 2009
    #3
    Ditto what mitchellr1705 said.

    iTunes is so ridiculously slow that it is unusable. It's not my computer - I just got a brand new MacBook.

    I figured it was because they've personalized every sort of recommendation they can think of. I've turned off every bell and whistle possible, but this hasn't helped. It is still ungodly slow.

    Hello Amazon, etc.

    I love Apple, but seriously, what can they possibly be thinking with regard to iTunes?
     
  4. mitchellr1705 thread starter macrumors newbie

    Joined:
    Jul 7, 2008
    #4
    I have just found a fix for this problem - uninstall iTunes, then go to the apple website and download the latest version.
    Your library will automatically show up in the new installed version and will work much quicker.
    Worked for me - so its worth a try
     
  5. joeliethegoalie macrumors member

    Joined:
    Nov 7, 2007
    Location:
    boulder,co
    #5
    I'm having this same issue. At first I thought it was due to my keeping my music folder on an external drive, but I ran benchmarks and tried loading tracks w/QT and VLC and there was no lag so the drive is not the issue. The drive maker suspects it's an iTunes issue.

    How far did you go w/the uninstall? Did you go through this entire process (http://support.apple.com/kb/HT1224), or just trash the app and download a new version?

    Thanks!
     
  6. mitchellr1705 thread starter macrumors newbie

    Joined:
    Jul 7, 2008
    #6
    Juts trash the app and the re-download and install it :)
     
  7. joeliethegoalie macrumors member

    Joined:
    Nov 7, 2007
    Location:
    boulder,co
    #7
    One more question...

    Were you experiencing delays with the iTunes Store, or within your own library as well?

    My issues involve iTunes being slow in playing my own music. I don't spend much time w/the store.

    Thanks.
     

Share This Page