iTunes remote cannot connect

Discussion in 'iOS Apps' started by farmerku, Aug 14, 2010.

  1. farmerku macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #1
    Since buying my first iPhone in November 2009 I have never successfully gotten the iTunes Remote app to work with my computer.

    To begin: My phone (and others I have tried) shows up in my iTunes, I am then prompted for the pass-code, I enter it, my iTunes accepts then I get this message on my phone.

    [​IMG]

    Now that I have an iPhone 4 I desperately want this app to work with my Mac and iTunes library.

    After months of research the problem is not my iPhone rather there is something wrong with my mac/snow leopard. I have researched and checked into this problem for MONTHS now with no success.

    Just to clarify--

    Both my Mac and iPhone are on the same wi-fi network

    I have my Snow Leopard firewall on but iTunes selected to "allow incoming connections"

    I have sharing enabled in iTunes

    I have tried the "forget all remotes"

    I have tried connecting other wi-fi networks to make sure it wasn't a router problem- no luck

    My roommate and two friends who have iphones are not able to connect to my library but we can all connect to their libraries

    I use apps like AirMouse with no problem


    Does anybody have the slightest clue as to what could be the problem here????

    Thanks in advance! 100,000 MacRumors points to the person who can help me with this and get this awesome app to work :cool:
     
  2. plinkoman macrumors 65816

    plinkoman

    Joined:
    Jul 2, 2003
    Location:
    New York
  3. farmerku thread starter macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #3
    No luck. Really appreciate the help though!
     
  4. t22design macrumors regular

    Joined:
    Nov 10, 2007
    #4
    I have remote.app problems with iOS 4 on iPhone 4, but not to this extent.

    Can you disable the firewall completely to try it?
     
  5. farmerku thread starter macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #5
    I have disabled the firewall completely and then restarted my computer to no avail. It really sucks because this was one of those apps that I always wanted when I didn't have an iPhone. I feel like a pc user all over again not getting things to work like they are suppose to.

    Does anybody know of an alternative app similar to remote?
     
  6. jasonwilldermoo macrumors newbie

    Joined:
    Apr 3, 2009
    #6
    I just went through the same nightmare. I renewed the lease on my Mac mini and it has worked fine since. This seemed to happen after the last iTunes update.
     
  7. farmerku thread starter macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #7
    I did a Verify Disk Permissions and got this warning...


    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    I can only assume this is part of my problem??????
     
  8. farmerku thread starter macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #8
    After hours... and I mean HOURS of researching this and trouble shooting, I am using the iTunes Remote and it is working great!!

    I found a terminal command that wiped all of the firewall settings and the app loading my library immediately. In case anyone else has this problem enter this into Terminal..

    sudo /sbin/ipfw -f flush
     
  9. Aristot3lis macrumors newbie

    Joined:
    Nov 17, 2010
    #9
    Thank you

    I haven't used remote app for almost a year and now because of you I can enjoy it again, thank you.
     
  10. badlydrawnboy macrumors 65816

    Joined:
    Oct 20, 2003
    #10
    Farmerku's solution solved my problem before, but I recently did a clean install of OS X and I'm experiencing it again. This time, however, the Terminal command isn't working. Now, when I enter the password to pair the iPhone with my iTunes library, it tells me the password is incorrect. It's not.

    I've tried the Terminal flush a few times, restarting iTunes, restarting computer, restarting iPhone, all to no avail. Wondering if this has something to do with iOS 4.2?
     

Share This Page