iTunes rental movie playback issue

Discussion in 'Mac Apps and Mac App Store' started by encomium23, Jul 7, 2011.

  1. encomium23, Jul 7, 2011
    Last edited: Jul 7, 2011

    encomium23 macrumors newbie

    Joined:
    May 20, 2011
    #1
    Hey guys.
    I have rented & downloaded the inside job. It has finished, moved itself from 'downloads' and has come up under "rentals" on the upper left hand side pane of itunes. i play the file and it loads up the player, but noting happens. the top display shows elapsed and time to go and i can drag the little diamond along the progress bar. but no playback. just a black screen. elapsed time does not change. i looks like it it paused on a black screen. the pause button is showing as if the file were playing, and i can toggle this between play and pause but still noting.

    The 'chapters' pull down menu is showing all the chapters with the first frame of the start of each chapter next to it. Obama is photogenic but was hoping to kinda see the whole thing in motion instead of 16 pictures in a drop menu :rolleyes:

    i have quit and re-started itunes and re-booted OSX and still no change. I also tried to open the file with quicktime but it said that it was not authorized and to use itunes. Tried with mplayer X but that was a waste of time too...

    This was a 1.5GB download and i only have 48hrs to watch it. What the hell is going on?! :)

    EDIT: all other movies / tv shows / music is playing fine. It's ONLY this file.... i have Tried to rent it again and itunes says that i have already rented it, would i like to again? (arrghh) i have also clicked on check for available downloads in case some of it was missing..
     
  2. encomium23 thread starter macrumors newbie

    Joined:
    May 20, 2011
    #2
    Now after re-starting for a second time, it works.... Thanks?

    MacRumors admin, feel free to remove this now useless post.
     

Share This Page