iTunes says I need 10.4.11 but I'm using 10.5.8!!!

Discussion in 'Mac Apps and Mac App Store' started by adman2010, Dec 29, 2009.

  1. adman2010 macrumors newbie

    Joined:
    Dec 29, 2009
    #1
    Yikes. Long-time reader. First-time poster. Would appreciate the help.

    I got a new iPod nano for XMAS. Installed the new iTunes and it is telling me that I need Safari 4.0.3 to access the iTunes music store. Simple fix, right?

    Wrong.

    I download the new Safari (4.0.4), and then it proceeds to tell me I can't install it on my HD because:

    "You cannot install Safari on this volume. This update requires Mac OS X 10.4.11."

    But I am running 10.5.8!!!

    So the vicious cycle begins. I have searched and searched and cannot find a thing on this. Any help would be appreciated.

    Regards,

    AM
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    There are different versions of Safari for 10.4 and 10.5. You need this one.
     

Share This Page